1146. Topological Order (25) 拓扑排序

10 篇文章 0 订阅
2 篇文章 0 订阅

1146. Topological Order (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (<= 1,000), the number of vertices in the graph, and M (<= 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (<= 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4


        给出一个拓扑图以及若干执行顺序,输出哪些顺序不能完成拓扑图。

        输入图的时候存储每个节点的入度以及下一步的节点即可。测试执行顺序的时候注意复制一份出来,保留原数据方便下一组测试(本来以为暴力循环复制会超时,没想到过了)。每输入一个点先检查入度是否为0,没有问题就依次把此点的下一点的入度减1。


#include <cstdio>
#include <cstdlib>
#include <list>
#include <vector>
#include <set>

using namespace std;

int N, M, K;
int inn[1001], inn2[1001];
vector<int>outv[1001];
vector<int>outv2[1001];

int main() {
	scanf("%d %d\n", &N, &M);
	int a, b;
	for (int i = 0; i < M; i++) {
		scanf("%d %d\n", &a, &b);
		outv[a].push_back(b);
		inn[b]++;
	}
	scanf("%d", &K);
	vector<int>ans;
	for (int i = 0; i < K; i++) {
		int f = 1;
		int vis[1001] = { 0 };
		for (int j = 1; j <= N; j++) {
			outv2[j] = outv[j];
			inn2[j] = inn[j];
		}
		for (int j = 0; j < N; j++) {
			scanf("%d", &a);
			if (vis[a])f = 0;
			else vis[a]++;
			if (f) {
				if (inn2[a])
					f = 0;
				else {
					for (int t = 0; t < outv2[a].size(); t++) {
						inn2[outv2[a][t]]--;
					}
				}
			}
		}
		if (!f) ans.push_back(i);
	}
	for (int i = 0; i < ans.size(); i++) {
		printf("%d%c", ans[i], i == ans.size() - 1 ? '\n' : ' ');
	}

	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值