oval and rectangle(积分)(输入格式)(签到)

                                     oval-and-rectangle

                                Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                               Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

Patrick Star find an oval.

The half of longer axes is on the x-axis with length a.

The half of shorter axes is on the y-axis with length b.

Patrick Star plan to choose a real number c randomly from [0,b], after that, Patrick Star will get a rectangle :

1. The four vertexes of it are on the outline of the oval.

2. The two sides of it parallel to coordinate axis.

3. One of its side is y=c.

Patrick Star want to know the expectations of the rectangle's perimeter.

Input

The first line contain a integer T (no morn than 10), the following is T test case, for each test case :

Each line contains contains two integer a, b (0<b<a<105). Separated by an white space.

Output

For each test case output one line denotes the expectations of the rectangle's perimeter .

You should keep exactly 6 decimal digits and ignore the remain decimal digits. 

It is guaranted that the 7-th decimal digit of answer wont be 0 or 9.

Sample Input

1 2 1

Sample Output

8.283185

很显然,今天没能成功签到,罚时比肩dls。

求几何里面周长的期望用微积分,这个可以想到,但是一直WA是因为printf采用四舍五入的小数保留法真的是不知道呀(感觉全场就我个弱鸡不知道)

 

 

#include<bits/stdc++.h>
#define show(a) cout<<#a<<'='<<a<<endl;
#define in(a) scanf("%d",&a)
#define ind(a) scanf("%lf",&a)
using namespace std;

int main()
{

   int T;
   const double pi=acos(-1.);
   in(T);

   while(T--)
   {
        double a,b;
      ind(a);ind(b);

      double ans=(a*pi+b*2.)*1e6;
      ans=floor(ans);
      ans/=1e6;
      printf("%.6lf\n",ans);
   }
   return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值