POJ1094--Sorting It All Out--拓补排序

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
#include <iostream>
#include <cstdio>
using namespace std;
#define maxn 28
int c[maxn];
int G[maxn][maxn];
int topo[maxn];
int n,t;
//判断是否矛盾可直接用刘汝佳的模板。判断是否唯一确定,一个只要夹在两个中间即可
bool dfs(int u)
{
	c[u]=-1;
	for(int i=0;i<n;i++)
	{
		if(G[u][i])
		{
			if(c[i]==-1)
			{
				return false;
			}
			else if(c[i]==0&&!dfs(i))
			{
				return false;
			}
		}
	}
	c[u]=1;topo[--t]=u;
	return true;
}
bool toposort()
{
	t=n;
	memset(c,0,sizeof(c));
	for(int i=0;i<n;i++)
	{
		if(!c[i])
		{
			if(!dfs(i))
				return false;
		}
	}
	return true;
}
bool judge()
{
	for(int i=1;i<n;i++)
	{
		if(!(G[topo[i-1]][topo[i]]))
		{
			return false;
		}
	}
	return true;
}
int main()
{
	int m;
	while(scanf("%d%d",&n,&m)==2&&(n||m))
	{
		bool flag=false,maodun=false;//flag用来判几次实现序列确定。maodun用来判断是否会矛盾
		memset(G,0,sizeof(G));
		char a,b,c;
		int sum,gg;
		memset(topo,0,sizeof(topo));
		for(int i=1;i<=m;i++)
		{//之前我把topo的置0放到循环了。贡献了无数个WA。。
			cin>>a>>b>>c;
			G[a-'A'][c-'A']=1;
			if(!maodun)
			{
				if(!toposort())
				{
					maodun=true;
					gg=i;
				}
				else 
				{
					if(!flag)
					{
						if(judge())
						{
							flag=true;
							sum=i;
						}
					}
				}
			}
		}
		if(flag)
		{
			printf("Sorted sequence determined after %d relations: ",sum);
			for(int i=1;i<=n;i++)
			{
				char xx=topo[i-1]+'A';
				cout<<xx;
			}
			cout<<"."<<endl;
		}
		else if(maodun)
		{
			printf("Inconsistency found after %d relations.\n",gg);
		}
		else cout<<"Sorted sequence cannot be determined."<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值