8.17--练习赛F题--Moo Volume

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise. 

FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.
Input
* Line 1: N 

* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).
Output
There are five cows at locations 1, 5, 3, 2, and 4.
Sample Input
5
1
5
3
2
4
Sample Output
40
Hint
INPUT DETAILS: 

There are five cows at locations 1, 5, 3, 2, and 4. 

OUTPUT DETAILS: 

Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.

题意:有n头牛,一头牛和另一头牛互相叫的音量是这两头牛之间的距离。求所有牛叫的音量是多少。

思路:一头牛叫另一头牛,另一头牛也要叫回来,所以只需要求一遍过去的,即从前往后的,然后求完了值以后*2就好了。

这道题本来是抱着试一试的心态交的。因为给的数据太大,怕用双重循环会超时。但是试了一发居然过了。。。下面直接贴代码了;

源代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include <iomanip>
#include <string>
using namespace std;
long long N;
long long Moo[10000000];
long long sum = 0;
int main()
{
    scanf("%lld",&N);
    for (long long i = 1; i <= N; i++)
        scanf("%lld",&Moo[i]);
    sort(Moo+1,Moo+N+1); //对位置进行排序
    for (long long i = 1; i <= N; i++)//从前往后的。结果*2
    {
        for (long long j = i + 1; j <= N; j++)
            sum += Moo[j] - Moo[i]; // 位置差
    }
    printf("%lld\n",sum * 2);
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值