树状数组专题--Problem B(二维树状数组)

Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year. 
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles. 
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position. 
 

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. There are 4 kind of queries, sum, add, delete and move. For example: S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points. A x1 y1 n1 means I put n1 books on the position (x1,y1) D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100. 
 

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. For each "S" query, just print out the total number of books in that area. 
 

Sample Input
  
  
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2
 

Sample Output
  
  
Case 1: 1 3 Case 2: 1 4

题意:一维数组的进化版。。二维数组。依旧是四种操作。增加,删除,移动,和求和。

源代码:

/*
 1001
 二维树状数组
 */
#include <iostream>
#include <cstring>
#include <algorithm>
#include <stdio.h>
#include <vector>
#define MAX 1005
using namespace std;
int C[MAX][MAX];
int a[MAX][MAX];
int lowbit(int x)
{
    return x & (-x);
}
int getsum(int x,int y)
{
    int ans = 0;
    for (;x > 0; x -= lowbit(x))
    {
        for (int i = y; i > 0; i -= lowbit(i))
            ans += C[x][i];
    }
    return ans;
}
void add(int x,int y,int v)
{
    for (;x < MAX; x += lowbit(x))
    {
        for (int j = y; j < MAX; j+= lowbit(j))
        {
            C[x][j] += v;
        }
    }
}
void down(int x,int y,int v)
{
    for (;x < MAX; x += lowbit(x))
    {
        for (int j = y; j < MAX; j += lowbit(j))
        {
            C[x][j] -= v;
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    for (int p = 1; p <= t; p++)
    {
        memset(C,0,sizeof(C));
        memset(a,0,sizeof(a));
        int n;
        scanf("%d",&n);
        printf("Case %d:\n",p);
        for (int i = 1; i < MAX; i++)//初始化
            for (int j = 1; j < MAX; j++)
            {
                add(i,j,1);
                a[i][j] = 1;
            }
        for (int i = 1; i <= n; i++)
        {
            char h;
            cin >> h;
            if (h == 'S')
            {
                int x1,y1,x2,y2;
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                x1++;//注意不能为0;
                x2++;
                y1++;
                y2++;
                int res;
                //cout << getsum(x2,y2) << endl;
                //cout << getsum(x1-1,y1-1) << endl;
                //cout << getsum(x1-1,y2)<<endl;
                //cout << getsum(x2,y1-1)<<endl;
                if (x1 > x2)//要保证x2,y2是大于x1,y1的。
                {
                    int m = x1;
                    x1 = x2;
                    x2 = m;
                }
                if (y1 > y2)
                {
                    int m = y1;
                    y1 = y2;
                    y2 = m;
                }
                res = getsum(x2,y2) + getsum(x1-1,y1-1) - getsum(x1-1,y2) - getsum(x2,y1-1);
                printf("%d\n",res);
            }
            else if (h == 'A')
            {
                int x,y,v;
                scanf("%d%d%d",&x,&y,&v);
                x++;
                y++;
                add(x,y,v);
                a[x][y] += v;
            }
            else if (h == 'D')
            {
                int x,y,v;
                scanf("%d%d%d",&x,&y,&v);
                x++;
                y++;
                if (a[x][y] < v)//拿走的数目也要判断。。。
                    v = a[x][y];
                down(x,y,v);
                a[x][y] -= v;
            }
            else if (h == 'M')
            {
                int x1,y1,x2,y2,v;
                scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&v);
                x1++;
                y1++;
                x2++;
                y2++;
                if (a[x1][y1] < v)//判断移动的书的数量是否超过可移动的书的数量
                    v = a[x1][y1];
                add(x2,y2,v);
                down(x1,y1,v);
                a[x1][y1] -= v;
                a[x2][y2] += v;
            }
        }
    }
    return 0;
}

心得:这个题需要注意的点有很多。。。wa了好多发。。。还需要考虑周全一点。

另外二维数组的这些操作还要加深印象加深理解。




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值