集训队专题(9)1004 See you~

See you~

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4414    Accepted Submission(s): 1396


Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year. 
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles. 
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position. 
 

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. 
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. 
There are 4 kind of queries, sum, add, delete and move. 
For example: 
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points. 
A x1 y1 n1 means I put n1 books on the position (x1,y1) 
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. 
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. 
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100. 
 

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. 
For each "S" query, just print out the total number of books in that area. 
 

Sample Input
  
  
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2
 

Sample Output
  
  
Case 1: 1 3 Case 2: 1 4
 

Author
Sempr|CrazyBird|hust07p43
 

Source
 

这题是小编做过的第一道关于二维树状数组的题,因为这题是裸的二维树状数组,在用法上没有什么好说的,只要大家理解了二维树状数组的概念就能相应的套模板解决。

其实如果一维的树状数组理解了二维的理解就不是什么问题,二维的相当于在纵向再加了一次树状结构,并与横向的树状构成了整个二维的树。(不知道小编这样讲大家能不能懂,这个问题真的是讲不怎么清楚点的,一定要结合一维的加以理解)

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 1002;
int c[maxn][maxn];
int Lowbit(int x)
{
	return x&(-x);
}
void update(int x,int y,int d)
{
	int i,j;
	for(i=x; i<maxn; i+=Lowbit(i))
		for(j=y; j<maxn; j+=Lowbit(j))
			c[i][j] += d;
}
int sum(int x,int y)
{
	int sum = 0,i,j;
	for(i=x; i>0; i-=Lowbit(i))
		for(j=y; j>0; j-=Lowbit(j))
			sum += c[i][j];
	return sum;
}
int main()
{
	int t,n,x1,y1,x2,y2,d,i,j;
	char s[5];
	scanf("%d",&t);
	for(int k=1; k<=t; k++)
	{
		scanf("%d",&n);
		printf("Case %d:\n",k);
		memset(c,0,sizeof(c));
		for(i=1; i<maxn; i++)
			for(j=1; j<maxn; j++)
				update(i,j,1);
		while(n--)
		{
			scanf("%s",s);
			if(s[0] == 'S')
			{
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				if(x1<x2) swap(x1,x2);
				if(y1<y2) swap(y1,y2);
				printf("%d\n",sum(x1+1,y1+1)-sum(x1+1,y2)-sum(x2,y1+1)+sum(x2,y2));
			}
			if(s[0] == 'A')
			{
				scanf("%d%d%d",&x1,&y1,&d);
				update(x1+1,y1+1,d);
			}
			if(s[0] == 'D')
			{
				scanf("%d%d%d",&x1,&y1,&d);
				int tmp = sum(x1+1,y1+1)-sum(x1,y1+1)-sum(x1+1,y1)+sum(x1,y1);
				d = tmp<d? tmp:d;
				update(x1+1,y1+1,-d);
			}
			if(s[0] == 'M')
			{
				scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&d);
				int tmp = sum(x1+1,y1+1)-sum(x1,y1+1)-sum(x1+1,y1)+sum(x1,y1);
				d = tmp<d? tmp:d;
				update(x1+1,y1+1,-d);
				update(x2+1,y2+1,d);
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值