poj-3048

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows. 

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not). 

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
Input
* Line 1: A single integer, N 

* Lines 2..N+1: The serial numbers to be tested, one per line
Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
Sample Input
4
36
38
40
42
Sample Output
38
Hint
OUTPUT DETAILS: 
19 is a prime factor of 38. No other input number has a larger prime factor.

要求求出有最大素因子的数

外层对素数从大到小循环,内层对n个数从前往后循环,这样第一个内整除较大素数的n[i]就是要找的数

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
int n,a[5010];
bool isprime[20002];
void work()
{
    int i,j;
    for(i=0;i<=20000;i++)
        isprime[i]=true;
    isprime[0]=isprime[1]=false;
    for(i=2;i<=20000;i++)
    {
        if(isprime[i])
        for(j=2*i;j<=20000;j+=i)
            isprime[j]=false;
    }
}
int main()
{
    int i,j,maxn=0;
    work();
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        if(a[i]>maxn) maxn=a[i];
    }
    int maxval=1;
    bool flag=false;
    for(i=maxn;i>=2;i--)
    {
        if(!isprime[i]) continue;
        for(j=1;j<=n;j++)
        {
            if(a[j]%i==0)
            {
                maxval=a[j];
                flag=true;
                break;
            }
        }
        if(flag) break;
    }
    printf("%d",maxval);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值