HDU 5606 tree 并查集

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=5606

tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1898    Accepted Submission(s): 808

Problem Description

There is a tree(the tree is a connected graph which contains n points and n−1 edges),the points are labeled from 1 to n,which edge has a weight from 0 to 1,for every point i∈[1,n],you should find the number of the points which are closest to it,the clostest points can contain i itself.

Input

the first line contains a number T,means T test cases.

for each test case,the first line is a nubmer n,means the number of the points,next n-1 lines,each line contains three numbers u,v,w,which shows an edge and its weight.

T≤50,n≤105,u,v∈[1,n],w∈[0,1]

Output

for each test case,you need to print the answer to each point.

in consideration of the large output,imagine ansi is the answer to point i,you only need to output,ans1 xor ans2 xor ans3.. ansn.

Sample Input

1

3

1 2 0

2 3 1

Sample Output

1

题意:

有一个树(n个点, n−1条边的联通图),点标号从1-n,树的边权是0或1.求离每个点最近的点个数(包括自己)。

思路:

因为求最近的点的个数,所以只要边的权值是0的,1就不是最近的了

将权值为0的边连接起来

并查集求联通块的大小

注意:题目输出的是,对每个点的相异或,然后输出最后的值

This is the code

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include <iomanip>
#include<list>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
#define MOD 1e9+7
#define LL long long
#define ULL unsigned long long     //1844674407370955161
#define INT_INF 0x7f7f7f7f      //2139062143
#define LL_INF 0x7f7f7f7f7f7f7f7f //9187201950435737471
const int dr[]={0, 0, -1, 1, -1, -1, 1, 1};
const int dc[]={-1, 1, 0, 0, -1, 1, -1, 1};
const int maxn=1e5+10;
int fa[maxn];
int num[maxn];

void init(int n)
{
    for(int i=0;i<=n;++i)
    {
        fa[i]=i;
        num[i]=0;
    }
}
int Find(int x)
{
    if(fa[x]==x)
        return x;
    else return fa[x]=Find(fa[x]);
}
void Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x!=y)
        fa[x]=y;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        init(n);
        for(int i=1;i<n;++i)
        {
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            if(!w)//权值是0
                Union(x,y);
        }
        for(int i=1;i<=n;++i)
        {
            fa[i]=Find(i);//求父节点
            num[fa[i]]++;//记录这个联通块的数量
        }
        int ans=0;
        for(int i=1;i<=n;++i)
            ans=num[fa[i]]^ans;//最后相异或输出
        printf("%d\n",ans);
    }
}


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值