HDOJ 3294 Girls' research 【Manacher算法+输出最长回文子串 + 字符转化】

Girls' research

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4876    Accepted Submission(s): 1822


 

Problem Description

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.

 

 

Input

Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.

 

 

Output

Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.

 

 

Sample Input

 

b babd a abcd

 

 

Sample Output

 

0 2 aza No solution!

 

 

Author

wangjing1111

 

 

Source

2010 “HDU-Sailormoon” Programming Contest

 

 

Recommend

 

题意:给你一个字符ch和一个字符串str(只有小写字母),ch代表字符串str中a字符的真身。其余字符类似作此变化。现在让你找出字符串中的最长回文子串,输出回文子串在原字符串的起点和终点,并输出它对应的真身。若有多个满足条件的子串,输出最先出现的。

分析:

马拉车算法的模型,但我尽然卡在了字母变换位置上,总以为一个公式就能出来,一种WA,但是只要分一下情况就很简单了。

对于确定位置的公式,输出一下变长的字符串,在草稿纸上分分情况模拟一下就ok

但我好像推麻烦了,一个int l=(pos-ans+1)/2-1就能解决,这个/2确实巧妙

#include<iostream>
#include<cstdio>
#include<string> 
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
 
const int maxn=1000010;
char str[maxn];//原字符串
char tmp[maxn<<1];//转换后的字符串
int Len[maxn<<1];
int pos;
//转换原始串
int init(char *st)
{
    int i,len=strlen(st);
    tmp[0]='@';//字符串开头增加一个特殊字符,防止越界
    for(i=1;i<=2*len;i+=2)
    {
        tmp[i]='#';
        tmp[i+1]=st[i/2];
    }
    tmp[2*len+1]='#';
    tmp[2*len+2]='$';//字符串结尾加一个字符,防止越界
    tmp[2*len+3]=0;
    return 2*len+1;//返回转换字符串的长度
}
//Manacher算法计算过程
int manacher(char *st,int len)
{
     int mx=0,ans=0,po=0;//mx即为当前计算回文串最右边字符的最大值
     for(int i=1;i<=len;i++)
     {
         if(mx>i)
         Len[i]=min(mx-i,Len[2*po-i]);//在Len[j]和mx-i中取个小
         else
         Len[i]=1;//如果i>=mx,要从头开始匹配
         
         while(st[i-Len[i]]==st[i+Len[i]])
                  Len[i]++;
         if(Len[i]+i>mx)//若新计算的回文串右端点位置大于mx,要更新po和mx的值
         {
             mx=Len[i]+i;
             po=i;
         }
         if(ans<Len[i])
		 {
		 	pos=i;
		 	ans=Len[i];
		 }
         
     }
     return ans-1;//返回Len[i]中的最大值-1即为原串的最长回文子串额长度
}
int main()
{
    char ch;
    while(~scanf("%c %s",&ch,&str))
    {
    	cin.get();
    	int t=ch-'a';
    	int len=strlen(str);
    	for(int i=0;i<len;i++)
		{
			if(str[i]-'a'>=t)
				str[i]=char(str[i]-t);
			else
				str[i]=char(str[i]-t+26);
		}
		 //cout<<str<<endl;
        int l=init(str);
	    
        int ans=manacher(tmp,l);
       //cout<<tmp<<endl<<ans<<" "<<pos<<endl;
        if(ans<=1)
        	printf("No solution!");
		else
		{
			int add=0,sub=0;
			if(tmp[pos]=='#')
				add=1;
			 else sub=1;
			int l=(pos-(ans-sub)+add)/2-1;
///int l=(pos-ans+1)/2-1;
			cout<<l<<" "<<l+ans-1<<endl;
			for(int i=l;i<=l+ans-1;i++)
			{
				printf("%c",str[i]);
			}
			cout<<endl;
		}
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值