数据结构实验之二叉树八:(中序后序)求二叉树的深度

Problem Description

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

Input

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

Output

输出二叉树的深度。

Example Input
2
dbgeafc
dgebfca
lnixu
linux
Example Output
4
3
code:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
typedef struct Bitnode
{
    char data;
    struct Bitnode *lchild, *rchild;
}Bitree;
Bitree *rebuild(char *a, char *b, int n)
{
    Bitree *T;
    int i;
    if(n==0) return NULL;
    T = (Bitree*)malloc(sizeof(Bitree));
    T->data = b[n-1];//因为b为后序所以b的最后一个元素即为二叉树的根;
    for(i = 0;i<n;i++)
    {
        if(a[i] == b[n-1]) break;//找到中序中第一个与根节点相等的元素,指向b中T的左支点;
    }
    T->lchild = rebuild(a, b, i);此时i指向b中T的左支点,此处的i相当于原来的最后一个元素处;
    T->rchild = rebuild(a+i+1, b+i, n-i-1);a与b首元素向后移动,同时(n-i-1)位置指向b中T的右支点;
    return T;
}
int max(int a, int b)
{
    if(a>b) return a;
    else return b;
}
int hight(Bitree *root)
{
    if(root==NULL) return 0;
    else return max(hight(root->lchild), hight(root->rchild))+1;
}
int main()
{
    int t;
    char a[51];
    char b[51];
    while(~scanf("%d", &t))
    {
        while(t--)
        {
            scanf("%s", a);
            scanf("%s", b);
            int str = strlen(a);
            Bitree *T;
            T = rebuild(a, b, str);
            int hi = hight(T);
            printf("%d\n", hi);
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值