Leading and Trailing

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

 我们给您两个整数:n和k,您的任务是找到  n的k次方  中     前三位数   和     后的三位数。

输出一个数k次幂后的后几位,是有一个模板的。

 如下所示:

ll init(ll a,ll b,ll mod)
{
    ll ans=1;
    while(b)
    {
 
        if(b%2==1)
            ans=ans*a%mod;
        a=a*a%mod;
        b/=2;
    }
    return ans%mod;
}

 同理,输出一个数k次幂后的前几位,也可以按这个模板来写。不过由于是除法,所以要换成double型。

double cmp(double x,double mod)
{
    while(x>=mod)
    {
        x/=10.0;
    }
    return x;
}


double ini(int n,int k,int mod)
{
    double sum1=1.0;
    double t=n*1.0;
    double mod1=mod*1.0;
    while(k)
    {
        if(k%2==1)
        {
            sum1=sum1*t;
            sum1=cmp(sum1,mod1);
        }
        t*=t;
        t=cmp(t,mod1);
        k/=2;
    }
    return sum1;
}

代码如下:

#include<stdio.h>
#define ll long long
ll init(ll a,ll b,ll mod)
{
    ll ans=1;
    while(b)
    {
 
        if(b%2==1)
            ans=ans*a%mod;
        a=a*a%mod;
        b/=2;
    }
    return ans%mod;
}

double cmp(double x)
{
    while(x>=1000.0)
    {
        x/=10.0;
    }
    return x;
}


double ini(int n,int k)
{
    double sum1=1.0;
    double t=n*1.0;
    while(k)
    {
        if(k%2==1)
        {
            sum1=sum1*t;
            sum1=cmp(sum1);
        }
        t*=t;
        t=cmp(t);
        k/=2;
    }
    return sum1;
}

int main()
{
    int m,w=1;
    ll n,k;
    scanf("%d",&m);
    while(m--)
    {
        scanf("%lld%lld",&n,&k);
        int sum2=(int)init(n,k,1000);
        int sum1=(int)ini(n,k);
        printf("Case %d: %d %03d\n",w++,sum1,sum2);
    }
    return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值