1060 Are They Equal (25 分)

1060 Are They Equal (25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​ , and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.12010^3 0.12810^3

测试点六 对于 3 0 0.0这个输入应该输出 YES 0.000*10^0

#include<bits/stdc++.h>
using namespace std;
int main() {
	int N, index1, index2, flag = 0;
	string s1, s2;
	cin >> N >> s1 >> s2;
	// 删除前导0
	while (s1[0] == '0') s1.erase(s1.begin());
	while (s2[0] == '0') s2.erase(s2.begin());
	index1 = s1.size();
	index2 = s2.size();
	//记录小数点的位置
	for (int i = 0; i < s1.size(); i++) {
		if (s1[i] == '.') {
			index1 = i;
			s1.erase(s1.begin() + i);
		}
	}
	for (int i = 0; i < s2.size(); i++) {
		if (s2[i] == '.') {
			index2 = i;
			s2.erase(s2.begin() + i);
		}
	}
	//处理0.0001这种数据
	while (s1[0] == '0') {
		s1.erase(s1.begin());
		index1--;
	}
	while (s2[0] == '0') {
		s2.erase(s2.begin());
		index2--;
	}
	//如果输入是 0 或者0.000
	if (s1 == "") {
		s1 = "0";
		index1 = 0;
	}
	if (s2 == "") {
		s2 = "0";
		index2 = 0;
	}
	//如果有效位数小于N要在后面补0
	while (s1.size() < N) s1 += '0';
	while (s2.size() < N) s2 += '0';
	if (index1 != index2) flag = 1;
	for (int i = 0; i < N; i++) {
		if (s1[i] != s2[i]) flag = 1;
	}
	if (flag == 0) {
		printf("YES 0.");
	} else {
		printf("NO 0.");
		for (int i = 0; i < N; i++) {
			printf("%c", s1[i]);
		}
		printf("*10^%d 0.", index1);
	}
	for (int i = 0; i < N; i++) {
		printf("%c", s2[i]);
	}
	printf("*10^%d", index2);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值