POJ 2377 Bad Cowtractors(最大生成树,2016河南多校大一训练赛)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13563 Accepted: 5603

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

Source



题意:

目的就是赚钱多,当然哪个边的权值大,用哪一个。


思路:

比赛那会,还以为是最短路!!水到家了。

转化为负边求解。挂了多次!-1的情况,重边的情况,键入数据错误的情况!!!


代码:

克鲁斯卡尔算法

#include<stdio.h>
#include<string.h>
#include<algorithm>
const int MYDD=1103;
using namespace std;

int set[MYDD];//存储节点信息
int n,m;
void init() {//并查集初始化
	for(int j=1; j<=n; j++)
		set[j]=j;
}

int find(int x) {
	return x==set[x]? x:find(set[x]);
}

bool combine(int x,int y) {//合并操作,并判断是否有环
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy) {
		set[fx]=fy;
		return true;
	}
	return false;//存在环
}

//int head[MYDD];
struct EDGE {
	int u,v,w,next;
} edge[MYDD+(int)1e5];
//void addedge(int u,int v,int w) {//边的增加
//	EDGE T= {u,v,w,haed[u]};
//	edge[numedge]=T;
//	head[u]=numedge++;
//}

bool cmp_edge(EDGE x,EDGE y) {
	return x.w<y.w;
}


int main() {
	scanf("%d%d",&n,&m);
	init();
	for(int j=0; j<m; j++)
		edge[j].w=-1;//边的初始化赋值

	for(int j=0; j<m; j++) {
		int u,v,w;
		scanf("%d%d%d",&edge[j].u,&edge[j].v,&w);
		if(w>edge[j].w)//选择最大权值的边
			edge[j].w=-w;//需要求解的是最大生成树
	}

	sort(edge,edge+m,cmp_edge);//边的权值为负值

	int ans=0;//答案
	int count=0;//选择边的数目
	int flag=0;
	for(int j=0; j<m; j++) {//把 m 写成了 n ,太粗心!!!!!!
		if(combine(edge[j].u,edge[j].v)) {
			ans+=edge[j].w;
			count++;
		}
		if(count+1==n) {
			flag=1;//生成树的性质
			break;
		}
	}
	if(flag)		printf("%d\n",-ans);//边的权值为负值
	else 			puts("-1");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值