HDU 1856 More is better(越多越好,并查集,节点的个数)

10 篇文章 0 订阅

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 24334    Accepted Submission(s): 8732


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 

Author
lxlcrystal@TJU
 

Source
 



题意:

找小朋友过来帮忙,小朋友都是相互认识的,一个来,彼此认识的也都跟着来了。问最可能来的是多少个。


思路:

记录和该节点相联系的其他节点的个数,最后找出最大值。


参考:CSDN。


AC代码:

#include<stdio.h>
#include<algorithm>
#define MYDD 11030
#define Q 10000002

using namespace std;

int pre[Q];
int deep[Q];//记录节点深度
void init() {//节点初始化
	for(int j=1; j<=Q; j++) {
		deep[j]=1;
		pre[j]=j;
	}
}

//int find(int x) {
//	return x==pre[x]? pre[x]:find(pre[x]);
//}

int find(int x) { //用上面的递归超时
	if(pre[x]!=x)
		pre[x]=find(pre[x]);
	return pre[x];
}

void combine(int x,int y) {
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy) { //不存在路径的压缩
		pre[fx]=fy;
		deep[fy]+=deep[fx];//合并到根节点
	}
}

int MAX(int x,int y,int z) {
	return (x>y? x:y)>z? (x>y? x:y):z;
}

bool cmp(int x,int y) {
	return x>y;
}

int main() {
	int n;
	while(scanf("%d",&n)!=EOF) {
		if(n==0) {
			puts("1");
			continue;
		}
		int a,b;
		init();//初始化
		int max_num=1;//记录出现的最大数字
		while(n--) {
			scanf("%d%d",&a,&b);
			combine(a,b);
			max_num=MAX(a,b,max_num);
		}

		sort(deep+1,deep+max_num+1, cmp);
		printf("%d\n",deep[1]);
	}
	return 0;
}


后:

递归查找父节点,数据量大了容易超时。

另外,rank 忘记是 C 的关键字了,总是运行错误。

****************************************************************



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值