1018. Public Bike Management (30)dijkstra记录路径+dfs最优值查找

1018. Public Bike Management (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.


Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,...N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->...->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0
     这道题目实在是太坑了,首先有点难是真的。然后,我觉得正常人的思路都是到达要调整的点后再顺着原路走回去,然后这道题不走回去,也就是说,带出来的自行车和带回去的自行车是可以同时不为0,这不是坑人吗,你要带回去就带回去,要带出来就带出来,干嘛这样玩啊。而且回去的话肯定要走最短路啊,那原路返回应该是最佳方案。真的是难以理解。好在这样的变态数据只有一组,姥姥还是很仁慈的。
     说一下解法,在用dijkstra算法的同时,在每个节点用prev数组记录该节点的前驱节点,在算法完成后,用dfs扫一遍,发现自行车不够了就多带几辆。表示我做了好几天。哎,真的有点担心PAT考试的时候回出现这种无厘头的题目。
# include <cstdio>
# include <queue>
# include <cstring>
# include <climits>
# include <queue>
# include <iostream>
# include <stack>
# include <cmath>
using namespace std;

const int debug = 0;
const int size = 505;

struct edge
{
    int to,value;
    edge(int _to,int _value):to(_to),value(_value){}
};
struct vertex
{	
    vector<edge> road;
	vector<int> miniroad;
	void Attach(edge adder)
	{
	     road.push_back(adder);   
	}  
	void AttachMini(int adder)
	{
	    miniroad.push_back(adder);     
	}
};
vertex v[size];
int bike[size];
int n,m,maxcapa,s;
typedef pair<int,int> point;
typedef vector<edge>::iterator edgeiter;
typedef vector<int>::iterator intiter;
void dijkstra(int start)
{
	int i,j;
    int dist[n+5];
    for (i=0;i<=n;i++)
        dist[i] = INT_MAX>>2;
	priority_queue<point,vector<point>,less<point> > pri_que;
	
	dist[start] = 0;
	pri_que.push(point(0,start));
	while (!pri_que.empty())
	{
	    point loca = pri_que.top();pri_que.pop();
	    if (loca.first >                                                                                                                                                              dist[loca.second])
	        continue;
        vector<edge>& locedge =  v[loca.second].road;
        for (edgeiter next = locedge.begin();next!=locedge.end();next++)
        {
		    if (dist[next->to] > next->value + dist[loca.second])
		         {
		         	 dist[next->to] = next->value + dist[loca.second];
				     pri_que.push(point(dist[next->to],next->to));
				     v[next->to].miniroad.clear();
				     v[next->to].miniroad.push_back(loca.second);
				 }
            else if (dist[next->to] == next->value + dist[loca.second])
                 {
				     v[next->to].miniroad.push_back(loca.second);
				 }
		}
	}
	if (debug)
	    for (i=0;i<=n;i++)
	       cout << i << ':' << dist[i] << endl; 
} 
void findPath(int s,int t,int bikeout,int bikein,int& ansbikeout,int &ansbikein,stack<int>& path,stack<int>& anspath)
{
    bikein += bike[s] - maxcapa/2;
	if (bikein < 0)
	    {if (debug) cout << "bikeout < 0" << endl;
		    bikeout -= bikein;
		    bikein = 0;
		} 
	if (s==t)
	    {
	    	if (bikeout < ansbikeout||(bikeout == ansbikeout&&bikein < ansbikein))
	    	    {
				    ansbikeout = bikeout;
				    ansbikein  = bikein;
				    anspath = path;
				}
	        return;
		}
    if (debug) cout << "s = " << s << ' ' << "bikein = " << bikein << ' ' << "bikeout = "<< bikeout << ' ' << "bike[s] = " << bike[s]<< "maxcapa = " << maxcapa <<endl; 
	vector<int> loca = v[s].miniroad; 
    for (intiter it = loca.begin();it!=loca.end();it++)
        {
        	path.push(*it);
		    findPath(*it,t,bikeout,bikein,ansbikeout,ansbikein,path,anspath);
		    path.pop();
		}
}
int main()
{
	int i,j,k,temp;
    
    cin >> maxcapa >> n >> s >> m;
    for (i=1;i<=n;i++)
        cin >> bike[i];
    while (m--)
    {
	    cin >> i >> j >> k;
	    v[i].Attach(edge(j,k));
	    v[j].Attach(edge(i,k));
	}
	dijkstra(s);
    stack<int> path,anspath;
    path.push(0);
    int ansbikeout = INT_MAX>>2;
    int ansbikein  = INT_MAX>>2;
    bike[0] = maxcapa/2; 
	findPath(0,s,0,0,ansbikeout,ansbikein,path,anspath); 
	cout << ansbikeout << ' '; 
	path = anspath;while (!anspath.empty()) anspath.pop();
    while (!path.empty())
        {
		   anspath.push(path.top());
		   path.pop();
		}
	while (!anspath.empty())
	    {
		cout << anspath.top();
	    anspath.pop();
	    if (!anspath.empty())
	        cout << "->";
		}
    cout << ' ' << ansbikein << endl; 
	
	return 0;
}
/*
If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.
*/
/*
Test Case:
100 6 1 15
78 54 0 37 36 82
0 1 7
0 2 4
0 3 7
0 4 7
0 5 2
1 2 9
1 3 1
1 4 2
1 5 5
2 3 1
2 4 2
2 5 7
3 4 4
3 5 7
4 5 7

The ans should be
46 0->2->3->1 28
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值