1090. Highest Price in Supply Chain (25)

1090. Highest Price in Supply Chain (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2

      题目大意呢,有一堆商人,其中除了一个最基础的供应商,其他的都必须从上一层供应商那里拿货,只有最终的销售商才卖东西,然后让我们算最贵的销售商在哪里。

      这道题目呢,如果建模比如A从B那里拿货,你就画一条从A指向B的线,最终会构成一个图,而且所有的线最终会指向那个题目中的“root supplier”,我们的目标是在这张图中找最长路。然后注意一下保存已经搜索过的答案就好了。

      还有一个方法并是DFS搜索,反正所有的线都是从根节点开始的,我们建图的时候就不要保存某某节点的祖先是谁了,直接保存某某节点的孩子是谁把,然后从根节点开始搜索,同时保存最长距离。不过我没试过。

      

# include <cstdio>
# include <iostream>
# include <cstring>
# include <cmath>
# include <algorithm>
using namespace std;

const int _size = 100000;
int chain[_size];
int lenth[_size];
int GetLenth(int i)
{
	if (lenth[i]!=-1)
	    return lenth[i];
    if (chain[i]==-1)
        return lenth[i] = 0;
    else 
        return lenth[i] = GetLenth(chain[i]) + 1; 
}
int main()
{
  memset(lenth,-1,sizeof(lenth));
  int n;
  double p,r;
  cin >> n >> p >> r;
  for (int i=0;i<n;i++)
      cin >> chain[i];
  int Max = -1;
  for (int i=0;i<n;i++)
      Max = max(GetLenth(i),Max);
  int count = 0;
  for (int i=0;i<n;i++)
      if (lenth[i]==Max)
          count++; 
  printf("%.2lf %d\n",p*pow(1+r/100,Max),count);
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值