HDOJ 1509 Windows Message Queue

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6336    Accepted Submission(s): 2579


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

Sample Input
  
  
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
  
  
EMPTY QUEUE!
msg2 10 msg1 10 EMPTY QUEUE!
#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>
#include<ctype.h>
#include<bits/stdc++.h>
using namespace std;
struct mess
{
    char msg[20];
    int par;
    int pri;
    int t;//记录当前message是具有相同键值的所有message中的第几个
};
priority_queue<mess> Q;//优先级队列
map<int,int> M;//建立映射map
bool operator < (const mess&a,const mess& b)//运算符重载(优先队列出队条件)
{
    if(a.pri!=b.pri)return a.pri>b.pri;
    return a.t>b.t;
}
int main()
{
    char cmd[4];
    while(cin>>cmd)
    {
        if(cmd[0]=='P')
        {
            mess newMsg;
            cin>>newMsg.msg>>newMsg.par>>newMsg.pri;
            newMsg.t=M[newMsg.pri]++;
            Q.push(newMsg);
        }
        else
        {
            if(Q.empty())cout<<"EMPTY QUEUE!"<<endl;
            else
            {
                mess outMsg =Q.top();
                Q.pop();
                cout<<outMsg.msg<<' '<<outMsg.par<<endl;
            }

        }
    }
    return 0;
}


  
  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值