Muddy roads(贪心)

Muddy roads
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3288 Accepted: 1511

Description

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools. 

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely. 

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.

Input

* Line 1: Two space-separated integers: N and L 

* Lines 2..N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap. 

Output

* Line 1: The miminum number of planks FJ needs to use.

Sample Input

3 3
1 6
13 17
8 12

Sample Output

5

Hint

INPUT DETAILS: 

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17. 

OUTPUT DETAILS: 

FJ can cover the mud pools with five planks of length 3 in the following way: 
                   111222..333444555....

                   .MMMMM..MMMM.MMMM....

                   012345678901234567890

Source


题意:

有n摊泥,长度为L,求最少需要多少目板才能覆盖这些泥?

思路:

贪心思想,对每个板的起点由小到大进行排序,然后就可以得出一个最小的值。注意终点 a[i].e-1;

代码:

# include <iostream>
#include <stdio.h>
#include <cstring>
#include <iomanip>
#include <cmath>
#include <algorithm> 
#define exp 1e-6
typedef long long ll;
using namespace std; 
struct node{
	int s;
	int e;
}a[10010];

bool cmp(node a,node b)
{
	return a.s<b.s;
}

int main()
{
	int n,L,i,j;
	ios::sync_with_stdio(false);
	cin>>n>>L;
	for(i=0;i<n;i++)cin>>a[i].s>>a[i].e;
	sort(a,a+n,cmp);
	int sum=0;
	int last=-1;
	for(i=0;i<n;i++)
	{
		if(last>=a[i].e)continue;
		if(last>a[i].s)
		{
			int length=a[i].e-last;
			int num=(length+L-1)/L;
			last+=num*L;
			sum+=num;
		}
		else
		{
			int length=a[i].e-a[i].s;
			int num=(length+L-1)/L;
			last=a[i].s+num*L;
			sum+=num;
		}
	}
	cout<<sum<<endl;
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值