Play on Words (有向图欧拉路判断)

地址:点击打开链接

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list. 
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题意:

给你多个单词,问你能不能将所有单词组成这样一个序列:序列的前一个单词的尾字母与后一个单词的头字母相同.

思路:

将每个单词的首尾字母看做一个节点,注意由于只能从单词首到单词尾,所以需要添加有向边, 有向图存在欧拉路必须满足两个条件:

(1)    有向图弱连通

(2).    图中所有点入度==出度 或只有两个点的入度!=出度且这两个中一个入度-出度=1,另一个出度-入度=1.

套模板即可。

代码:

#include<cstdio>  
#include<cstring>  
#include<vector>  
#include<queue>  
using namespace std;  
const int maxn=26+5;
int fa[maxn];
int in[maxn],out[maxn];
int n,m; 
char s[1500];
int findset(int i){
	if(fa[i]==-1)  return i;
	return fa[i]=findset(fa[i]);
	
}
int main()  
{
	int T;
	scanf("%d",&T);
	while(T--){
		memset(fa,-1,sizeof(fa));
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		scanf("%d",&m);
		for(int i=0;i<m;i++){
			scanf("%s",s);
			int len=strlen(s);
			int u=s[0]-'a';
			int v=s[len-1]-'a';
			in[v]++;
			out[u]++;
			u=findset(u);
			v=findset(v);
			if(v!=u){
				fa[u]=v;
			}
		}
		int cnt=0;
		for(int i=0;i<26;i++) 
		if((in[i]||out[i])&&findset(i)==i){
			cnt++;
		}
		if(cnt>1){
			printf("The door cannot be opened.\n");  
            continue;  
		}
		int c1=0,c2=0,c3=0;
		for(int i=0;i<26;i++){
			if(in[i]==out[i]) continue;
			else if(in[i]-out[i]==1) c1++;
			else if(out[i]-in[i]==1) c2++;
			else c3++;
		}
		if(((c1==c2&&c1==1)||(c1==c2&&c1==0))&&c3==0){
		    printf("Ordering is possible.\n");
		}
		else 
		printf("The door cannot be opened.\n");  
	}
    return 0;  
}  

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值