ACM: 一道水题 poj1723

 

                                                                            SOLDIERS

Description

N soldiers of the land Gridland are randomly scattered around the country.
A position in Gridland is given by a pair (x,y) of integer coordinates. Soldiers can move - in one move, one soldier can go one unit up, down, left or right (hence, he can change either his x or his y coordinate by 1 or -1).

The soldiers want to get into a horizontal line next to each other (so that their final positions are (x,y), (x+1,y), ..., (x+N-1,y), for some x and y). Integers x and y, as well as the final order of soldiers along the horizontal line is arbitrary.

The goal is to minimise the total number of moves of all the soldiers that takes them into such configuration.

Two or more soldiers must never occupy the same position at the same time.

Input

The first line of the input contains the integer N, 1 <= N <= 10000, the number of soldiers.
The following N lines of the input contain initial positions of the soldiers : for each i, 1 <= i <= N, the (i+1)st line of the input file contains a pair of integers x[i] and y[i] separated by a single blank character, representing the coordinates of the ith soldier, -10000 <= x[i],y[i] <= 10000.

Output

The first and the only line of the output should contain the minimum total number of moves that takes the soldiers into a horizontal line next to each other.

Sample Input

5

1 2

2 2

1 3

3 -2

3 3

Sample Output

题意:求所有的士兵排在同一行,任意两个不能同一个position,使用最少的步数.

个人思路: 1. 没什么好讲得中位数 + quickSort.

                   2. 纵轴上走的最少步数是:y1,y2,y3,...,yn. (已经排好序的序列)

                   y_mid = y[n/2], y_steps = ∑ ( |y[i]-y_mid| ).

                   3. 横轴上走的最少步数是:x1,x2,x3,...,xn (已经排好序的序列)

                   横轴的中位数是 (x[i]-i-1) 排序后的序列的中位数.

                   x_mid = z[n/2] , x_steps = ∑( |z[i]-x_mid| )

                   4. 结果: y_steps+x_steps. 

代码:

#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
#define MAX 10005

int cmp(void const *a,void const *b)
{
       return *((int*)a) - *((int*)b);
}

int abs(int x)
{
       if(x > 0)
             return x;
       else
             return -x;
}

int main()
{

      int n;
// freopen("a.txt","r",stdin);
      while(cin >> n)
     {
           int x[MAX] , y[MAX] , z[MAX];
           int i;
           int num = 0;
           for(i = 0; i < n; ++i)
           {
                 cin >> x[i] >> y[i];
           }
           qsort(x,n,sizeof(int),cmp);
           qsort(y,n,sizeof(int),cmp);

          for(i = 0; i < n; ++i)
                z[i] = x[i] - i - 1;
          qsort(z,n,sizeof(int),cmp);

          for(i = 0; i < n; ++i)
         {
                num += ( abs(y[i]-y[n/2]) + abs(z[i]-z[n/2]) );
         }

          cout << num << endl;
   }

      return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值