ACM: 序列中找最小逆序对 杂题 TOJ…

             Minimum Inversion Number

描述

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

输入

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

输出

For each case, output the minimum inversion number on a single line.

样例输入

10

1 3 6 9 0 8 5 7 4 2

样例输出

16

 

题意: 在规定的变化序列中找出最少逆序对的个数.

 

解题思路:

                1. 先计算出初始序列的逆序对的个数.

                2. 再计算把当前序列最后一个数放到最前面的时候逆序对变化.

                问题分析:  假设 sum 表示当前序列的逆序对数. num表示当前序列最后一个数.

                                要计算变化的情况首先, 假设最坏的情况. 即: sum -= (n-1);

                                再 sum += (num的逆序对)*2

                 3. 不断更新最小值.

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 5005

int n;
int sum;
int minsize;
int a[MAX];

int main()
{
 freopen("input.txt","r",stdin);
 int i, j;
 while(scanf("%d",&n) != EOF)
 {
  sum = 0;
  for(i = 0; i < n; ++i)
   scanf("%d",&a[i]);
  
  for(i = 0; i < n; ++i)
  {
   for(j = i+1; j < n; ++j)
   {
    if(a[i] > a[j])
     sum++;
   }
  }

  minsize = sum;
  for(i = n-1; i > 0; --i)
  {
   sum = (sum - (n-1));
   sum = (sum + (a[i]*2));
   if(minsize > sum)
    minsize = sum;
  }
  printf("%d\n",minsize);
 }
 return 0;
}

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值