UVA 10780-Again Prime? No Time. (数学-质因子)

Description

Download as PDF

Again Prime? No time.
Input: standard input
Output: standard output
Time Limit: 1 second


The problem statement is very easy. Given a number n you have to determine the largest power of m, not necessarily prime, that divides n!.

 

Input

 

The input file consists of several test cases. The first line in the file is the number of cases to handle. The following lines are the cases each of which contains two integers m (1<m<5000) and n (0<n<10000). The integers are separated by an space. There will be no invalid cases given and there are not more that 500 test cases.

Output

 

For each case in the input, print the case number and result in separate lines. The result is either an integer if m divides n! or a line "Impossible to divide" (without the quotes). Check the sample input and output format.

 

Sample Input

2
2 10
2 100

Sample Output

Case 1:
8
Case 2:
97

 


                                                                                                                                                                                                                                                                                                                       

题目要求得到 能被n ! 整除的m 的最多次幂。

若m 是素数时,只要将n 的阶层中的所有数单个整除m 即可。若m 非素数,则 阶层中其他书整除之后得到的数相乘得到的数可以整除m。

所以题目转化成求m 的质因子,和质因子的幂,最少数目的幂就是答案。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

int prime[5005],p[5005];

bool is_prime(int x)
{
    for(int i=2;i*i<=x;i++)
    {
        if(x % i == 0) return false;
    }
    return true;
}
void prime_biao()
{
    int cnt=0;
    for(int i=2;i<=5005;i++)
    {
        if(is_prime(i)) prime[cnt++]=i;
    }
}
int seize(int n)
{
    int k=0;
    memset(p,0,sizeof(p));
    for(int i=0;i<n;i++)
    {
        if(n < prime[i]) break;
        if(n % prime[i] == 0)
        {
            p[k++] = prime[i];
        }
    }
    return k;
}
int mul(int nn,int m)
{
    int ans =0 ;
    for(int i=m;i<=nn;i++)
    {
        int ii=i;
        while(ii > 0)
        {
            if(ii % m) break;
            if(ii % m == 0) {
                ans++;
                ii /=m;
            }
        }
    }
    return ans;
}
int mul2(int n,int m)
{
    int ans=0;
    while(n>0){
        if(n % m) break;
        if(n % m ==0){
            ans++;
            n /= m;
        }
    }
    return ans;
}
int main()
{
    //freopen("in.in","r",stdin);
    int T,m,n;
    scanf("%d",&T);
    prime_biao();
    for(int t_=1;t_<=T;t_++)
    {
        scanf("%d%d",&m,&n);
        int kk=seize(m);
        int ans = inf;
        for(int i=0;i<kk;i++)
        {
            int a=mul(n,p[i])/mul2(m,p[i]);
            ans = min(ans, a);
        }
        if(ans == 0) {
            printf("Case %d:\nImpossible to divide\n",t_);
            continue;
        }
        printf("Case %d:\n%d\n",t_,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值