ZOJ 3366 - Light Bulb(三分)

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house.Every night, he is wandering in his incommodious house, thinking of how to earn more money.One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house.A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line.H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall.All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

--------------------------------------------------

题意:

给出灯高,人高,两墙之间的距离D,求出影子的最大长度。

思路:

假设人与墙距离x, 设x+影子长L = s,当s < D时,L= s - x ; 当s >= D时,L= D - x + H - D * (H - h) / x。代码是这样的思路。

看别人的代码,其实前面s<D时随x的增大而增大,所以可以使得三分的左值一开始为l =(H-h)*D/H .

精度要至少设为eps = 1e-9才足够。

CODE:

#include <iostream>
#include <cstdio>

using namespace std;
const double eps = 1e-9;
double H, h, D;

double cal(double x)
{
    double s = H * x / (H - h);
    if(s >= D) return D - x + H - D * (H - h) / x;
    return s - x;
}
void solve()
{
    double l = 0.0, r = D, mid, mmid;
    while(r - l > eps) {
        mid = l + (r - l) / 3.0;
        mmid = r - (r - l) / 3.0;
        if(cal(mid) > cal(mmid)) r = mmid;
        else  l = mid;
    }
    printf("%.3lf\n", cal(l));
}
int main()
{
//freopen("in", "r", stdin);
    int T;
    scanf("%d", &T);
    while(T--) {
        scanf("%lf %lf %lf", &H, &h, &D);
        solve();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值