问题 K: 【组合数学】Round Numbers

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

输入
Line 1: Two space-separated integers, respectively Start and Finish.

输出
Line 1: A single integer that is the count of round numbers in the inclusive range Start…Finish

样例输入
复制样例数据
2 12
样例输出
6

首先要相求[a , b]里面的个数,只需要用[0 , b + 1] - [0 , a] , 为何不是[0 , b] - [0 , a - 1]的原因是下面求的是[0 , k]里面小于k 的round numbers, ,然后将考虑求[0 , k] 里面的round numbers个数,首先将k转化为二进制存在一个数组里面 , 长度为b[0] , 因为题目说了, 最高位肯定为1, 所以我们先求一下长度为b[0] - 1的有多少种round numbers, 这个长度的我们只要满足0的个数大于1的个数的就是一个round numbers, 因为长度为len - 1 , 永远比k小, 永远符合条件, 所以

	for(int i = 1 ;i < b[0] - 1 ;i ++)
	 for(int j = i / 2 + 1 ;j <= i ;j ++)
	  sum += c[i][j] ;

借用一下数学一本通上面的图片
在这里插入图片描述
在这里插入图片描述在这里插入图片描述

#include <iostream>
using namespace std;
int c[33][33] ;
int b[35] ;
void prepare()
{
	for(int i = 0 ;i <= 32 ;i ++)
	 for(int j = 0 ;j <= i ;j ++)
	  if(!j || i == j)
	   c[i][j] = 1 ;
	  else c[i][j] = c[i - 1][j] + c[i - 1][j - 1] ;
	return ; 
}
void solve(int n)
{
	b[0] = 0 ;
	while(n)
	 b[ ++ b[0]] = n % 2 , n /= 2 ;
	return ;
}
int calc(int n)
{
	solve(n) ;
	int sum = 0 ;
	for(int i = 1 ;i < b[0] - 1 ;i ++)
	 for(int j = i / 2 + 1 ;j <= i ;j ++)
	  sum += c[i][j] ;
	int zero = 0 ;
	for(int i = b[0] - 1 ; i >= 1 ;i --)
	 if(b[i])
	  for(int j = (b[0] + 1) / 2 - zero - 1 ;j <= i - 1 ;j ++)
	   sum += c[i - 1][j] ;
	 else zero ++ ;
	 return sum ;
}
int main()
{
	prepare() ;
	int a , b ; 
	cin >> a >> b ;
	cout << calc(b + 1) - calc(a) << endl ; 
	return 0 ;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值