[ACM] hdu 1087 Super Jumping! Jumping! Jumping! (动态规划)

286 篇文章 140 订阅
49 篇文章 0 订阅

Super Jumping! Jumping! Jumping!

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

 

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

 

Input

 

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N  
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

 

Output

 

For each case, print the maximum according to rules, and one line one case.

 

Sample Input

 

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

 

Sample Output

 

4
10
3

 

Author

 

lcy

 

解题思路:

类似最长递增子序列的想法,只不过这里求的是到第i个元素时,最长递增子序列,各个元素的和。求最大的那个值。

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=1002;
int num[maxn];
int sum[maxn];
int n;

int main()
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        sum[1]=num[1];
        int ans=sum[1];
        for(int i=2;i<=n;i++)
        {
            sum[i]=num[i];
            for(int j=1;j<i;j++)
            {
                if(num[j]<num[i]&&sum[j]+num[i]>sum[i])//满足递增且当前的sum[i]小与前面中的sum[j]+当前的数
                    sum[i]=sum[j]+num[i];//sum[i]为最长递增子序列的和,当前num[i]必选。
            }
            if(ans<sum[i])
                ans=sum[i];
        }
        printf("%d\n",ans);

    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值