航院 6213 Chinese Zodiac

                                 Chinese Zodiac

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 121    Accepted Submission(s): 90


Problem Description
The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be
2 years. But if the signs of the couple is the same, the answer should be 12 years.
 

Input
The first line of input contains an integer T (1T1000) indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.
 

Output
For each test case output an integer in a line.
 

Sample Input
  
  
3 ox rooster rooster ox dragon dragon
 

Sample Output
  
  
8 4 12
 
题意概括:给出一个女人和一个更年轻的男人两个人的生肖,求两个人之间年龄相差多少年。

解题思路:
1: 将所有的属相存入一个二维数组,并由1~12进行编号
2: 将输入的属相与二维数组中的属相比较,若相同,则将其编号赋给一个变量
3: 将两个变量进行比较,若女人的属相编号小于男人的属相编号,则用男人的属相编号减去女人的属相编号;若女人的属相编号大于男人的属相编号,则用男人的属相编号加上12在减去女人的属相编号;若两人属相相同,则输出12.

错误原因:无错误,一次过。

经验总结:
1: 用strcmp判断两个字符串,若相同时返回0. 此时如果要用if语句进行判断,加上非符号!,即可。

我的AC代码:

#include<stdio.h>
#include<string.h>
char s[13][12] = {"0","rat","ox","tiger","rabbit","dragon","snake","horse","sheep","monkey","rooster","dog","pig"};
int main(void)
{
 char s1[12], s2[12];
 int i, n, m, T;
 scanf("%d", &T);
 while(T--)
 {
  scanf("%s%s", &s1, &s2);
  for(i = 1; i <= 12; i ++)
  {
   if(!strcmp(s1, s[i]))
   {
    n = i;
   }
   if(!strcmp(s2, s[i]))
   {
    m = i;
   }  
  }
  if(n ==m)
  {
   printf("12\n");
  }
  else if (n < m)
  {
   printf("%d\n", m - n);
  }
  else
  {
   printf("%d\n", m + 12 -n);
  }
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值