hdu4734F(x)

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2188    Accepted Submission(s): 827


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
 

Source
2013 ACM/ICPC Asia Regional Chengdu Online

 我们定义十进制数x的权值为f(x) = a(n)*2^(n-1)+a(n-1)*2(n-2)+...a(2)*2+a(1)*1,a(i)表示十进制数x中第i位的数字。


  题目给出a,b,求出0~b有多少个不大于f(a)的数。

第一次独立用递归完成数位dp

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
using namespace std;
int dp[20][(1<<9)*9],bit[20];
int dfs(int len,int sum,bool e)
{
	if(len==0)
		return sum>=0;
	if(!e&&dp[len][sum]!=-1)
		return dp[len][sum];
	int n=e?bit[len]:9,ans=0;
	for(int i=0;i<=n;i++)
	{
		int t=sum-i*(1<<len-1);
		if(t>=0)
			ans+=dfs(len-1,t,e&&i==n);
		else
			break;
	}
	return e?ans:dp[len][sum]=ans;
}
int cg(int x)
{
	int tail=0;
	while(x)
	{
		bit[++tail]=x%10;
		x/=10;
	}
	return tail;
}
int cnt(int x)
{
	int ans=0;
	for(int i=cg(x);i>0;i--)
		ans+=(1<<i-1)*bit[i];
	return ans;
}
int main()
{
	memset(dp,-1,sizeof(dp));
	int T;
	cin>>T;
	for(int cs=1;cs<=T;cs++)
	{
		int a,b;
		cin>>a>>b;
		int sum=cnt(a),ans=dfs(cg(b),sum,1);
		cout<<"Case #"<<cs<<": "<<ans<<endl;
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值