区间DP_Halloween Costumes_light oj_1422

Halloween Costumes
Time Limit: 2000MSMemory Limit: 32768KB64bit IO Format: %lld & %llu

Submit Status uDebug

Description

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4

题意:给你n天需要穿的衣服的样式,每次可以套着穿衣服,脱掉的衣服就不能再用了(可以再穿),问至少要带多少条衣服才能参加所有宴会

http://lightoj.com/volume_showproblem.php?problem=1422

思路:首先dp[i][j]代表从区间i到区间j需要的最少穿衣服数量,我采取的是从下向上更新的。那么,面临第i件衣服,首先我们考虑穿上它,那么它所在的区间dp[i][j]=dp[i+1][j]+1;

接着考虑是否可以不用穿上它?在什么条件下,可以不用穿这件衣服呢?只有当区间i+1~~j里面已经穿过这件衣服的时候,就可以考虑不用再穿这件衣服。那么假设i+1<=k<=j

其中第k件衣服与第i件一样,那么第k件衣服穿上,第i件衣服不穿的情况的最少穿衣数==dp[i+1][k-1]+dp[k][j];第i件衣服不穿,那么就从第i+1件衣服开始计算,第k件衣服存在,那么在这个断点,我们该怎么判断是dp[i+1][k-1]+dp[k][j]呢?可以直接从数据推导出这个关系,也可以这样,在第k区间的时候,a[k]可能不是它自己本身穿的,而是在第k区间到第j区间,存在一个k<tmp<=j,有a[tmp]==a[k]......所以会是dp[i+1][k-1]+dp[k][j]........

代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#define INF 0x3fffffff
using namespace std;
int dp[105][105];
int a[105];
int main(){

    int T;
    scanf("%d",&T);
        int t = 1;
    while(T--){
        int n;
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= n; i++)
            scanf("%d",&a[i]);
        for(int i = 1; i <= n; i++)
            dp[i][i] = 1;
        for(int i = 2; i <= n; i++){
            for(int j = 1; j <= n; j++){
                dp[j][j+i-1] = 1 + dp[j][j+i-2];
                int temp = INF;
                int theend = j+i-1;
                for(int k = theend -1; k >= j; k--){
                    if(a[k] == a[theend])temp = min(temp,dp[j][k-1]+dp[k][theend-1]);
                }
                dp[j][j+i-1] = min(temp,dp[j][j+i-1]);
            }
        }
        printf("Case %d: %d\n",t++,dp[1][n]);
    }

}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REaDME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
好的,以下是使用 SQL 的 INSERT INTO 语句生成 CREATE TABLE EVENTS 并插入 10 条记录的代码: ``` CREATE TABLE EVENTS ( event_id INT NOT NULL, time DATETIME, event_location VARCHAR(255), theme VARCHAR(255), participants VARCHAR(255), PRIMARY KEY (event_id) ); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (1, '2021-01-01 09:00:00', 'New York', 'New Year Party', 'John, Mary, Tom'); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (2, '2021-02-14 18:00:00', 'Paris', 'Valentine's Day Dinner', 'Peter, Jane'); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (3, '2021-03-08 12:30:00', 'London', 'Women's Day Seminar', 'Emily, Lucy, Kate'); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (4, '2021-04-22 10:00:00', 'Tokyo', 'Business Conference', 'David, Michael, Sarah'); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (5, '2021-05-01 14:00:00', 'Berlin', 'May Day Parade', 'Anna, James, Lisa'); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (6, '2021-06-18 19:30:00', 'Sydney', 'Music Festival', 'Alex, Emma, Oliver'); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (7, '2021-07-04 16:00:00', 'Washington D.C.', 'Independence Day Celebration', 'Robert, Sophie'); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (8, '2021-08-20 11:00:00', 'Dubai', 'International Trade Fair', 'Daniel, Rachel, Eric'); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (9, '2021-09-10 15:45:00', 'Beijing', 'Science and Technology Conference', 'Grace, Frank, Wendy'); INSERT INTO EVENTS (event_id, time, event_location, theme, participants) VALUES (10, '2021-10-31 20:00:00', 'Los Angeles', 'Halloween Party', 'Jack, Oliver, Mia'); ``` 请注意,这是一个示例代码,如果您的实际需求与此不同,请相应地修改代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值