geometry 基础数学题,(自己易错)


A - geometry
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

There is a point $P$ at coordinate $(x,y)$. 
A line goes through the point, and intersects with the postive part of $X,Y$ axes at point $A,B$. 
Please calculate the minimum possible value of $|PA|*|PB|$.
 

Input

the first line contains a positive integer T,means the numbers of the test cases. 

the next T lines there are two positive integers X,Y,means the coordinates of P. 

$T=500$,$0< X,Y\leq 10000$. 
 

Output

T lines,each line contains a number,means the answer to each test case. 



 

Sample Input

     
     
1 2 1
 

Sample Output

     
     
4 in the sample $P(2,1)$,we make the line $y=-x+3$,which intersects the positive axis of $X,Y$ at (3,0),(0,3).$|PA|=\sqrt{2},|PB|=2\sqrt{2},|PA|*|PB|=4$,the answer is checked to be the best answer.
 

题意:一条直线经过p点,交X,Y坐标轴于A,B点,求pA*PB的最短距离。本来是一个简单的题目,被自己想复杂,还有自己一开始就基本不等式用错了地方。我以为PA=PB的时候最少,因为PA*PB《=(PA*PA+PB*PB)/2。后来根据例子,不对。所以就反应过。如果PA*PA+PB*PB是确定的话,那就可以这么用,基本不等式是最后求出来是一个常数,把高中数学知识全忘了。后来的方法,是自己笔算,设一个直线方程,将PA*PB表示出来。发现了可以用基本不等式了。

代码:

#include<stdio.h>
int main(){
	int t;
	scanf("%d",&t);
	int a,b;
	while(t--){
		scanf("%d%d",&a,&b);
		printf("%d\n",a*b*2);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值