PAT甲级-Finding Average

1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

 

题意大意是:给出一串数字,判断其中的合法数字【-1000<=x<=1000且x是小数点后不超过两位的浮点数】,并输出其平均值

 自己写了一大堆判断,乱七八糟的,看了大佬们的博客才晓得可以用sscanf和sprintf这种好用的东西,注意输出的时候的几个坑,然后就没有什么太大的问题了

#include <iostream>
#include <cstring>
#include <cstdio>
#include<algorithm>
#include <cmath>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 2e3+7;

int main()
{
    int n;
    double temp,ans=0;
    char input[1000],p[1000];
    scanf("%d",&n);
    memset(input,0,sizeof(input));
    int cnt = 0;
    for(int i = 0; i < n; i ++)
    {
        bool func = true;
        cin >> input;
        sscanf(input,"%lf",&temp);
        int l = strlen(input);
        sprintf(p,"%.2lf",temp);
        //cout << p <<" "<< input << endl;
        for(int j = 0; j < l; j ++)
        {
            if(input[j]!=p[j])
            {
                //cout << input << " " << p << endl;
                func = false;
                break;
            }
        }
        if(func&&temp >= -1000 && temp <= 1000){cnt++; ans += temp;}
        else printf("ERROR: %s is not a legal number\n",input);
    }
    if(cnt == 0) printf("The average of 0 numbers is Undefined\n");
    else if(cnt == 1)printf("The average of 1 number is %.2lf\n",ans/cnt);
    else printf("The average of %d number is %.2lf\n",cnt,ans/cnt);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值