hdu2899:Strange fuction(模拟退火算法)

Problem Description

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

 

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

 

Sample Input

2

100

200

 

Sample Output

-74.4291

-178.8534

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;

#define T 100
#define eps 1e-8
#define delta 0.98
#define INF 0x7fffffff
const int maxn = 3;
double x[maxn];
double Random() {
	double x = rand() * 1.0 / RAND_MAX;
	if(rand() & 1) x *= -1;
	return x;
}
double f(double x, double y) {
	return 6 * x * x * x * x * x * x * x + 8 * x * x * x * x * x * x + 7 * x * x * x + 5 * x * x - y * x;
}
void init() {
	for(int i = 0; i < maxn; i++) {
		x[i] = fabs(Random()) * 100;
	}
}
double Search(double y) {
	double t = T;//初始化温度
	double ans = INF;
	while (t > eps) {
		for(int i = 0; i < maxn; i++) {//随机选3个起点 只选一个也可以  不随机选也可以  根据时间复杂度改变吧  最多10个  
			double temp = f(x[i], y);             
			for(int j = 0; j < maxn; j++) {
				double xx = x[i] + Random() * t;
				if(xx - 0 >= -eps && xx - 100 <= eps) {
					double fx = f(xx, y);
					if(fx < temp) {
						x[i] = xx;
						temp = fx;
					}
				}
			}
			ans = min(ans, temp);
		}
		t *= delta;
	}
	return ans;
}

int main() {
	int TT;
	scanf("%d", &TT);
	while (TT--) {
		init();
		double y, ans;
		scanf("%lf", &y);
		ans = Search(y);
		printf("%.4lf\n", ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值