hdu 1228 A+B (字符串处理) 水

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11543    Accepted Submission(s): 6699

Problem Description
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出.  
Output
对每个测试用例输出1行,即A+B的值.
Sample Input
   
   
one + two = three four + five six = zero seven + eight nine = zero + zero =
Sample Output
   
   
3 90 96
Source
#include <iostream>
#include <cstring>
#include <stdio.h>
using namespace std;
int value(char c[])
{
    int n;
    if(!strcmp(c,"zero"))
        n=0;
    else if(!strcmp(c,"one"))
        n=1;
    else if(!strcmp(c,"two"))
        n=2;
    else if(!strcmp(c,"three"))
        n=3;
    else if(!strcmp(c,"four"))
        n=4;
    else if(!strcmp(c,"five"))
        n=5;
    else if(!strcmp(c,"six"))
        n=6;
    else if(!strcmp(c,"seven"))
        n=7;
    else if(!strcmp(c,"eight"))
        n=8;
    else
        n=9;
    return n;
}
int main()
{
    char  a[10],s;
    int i=0,sum;
    while(cin>>a)
    {
       sum=value(a);
       char b[10],c[10],d[10];
       cin>>b;
       if(b[0]=='+')
       {
           cin>>c;
           cin>>d;
           if(d[0]=='=')
           {
               sum+=value(c);
               cout<<sum<<endl;
           }
           else
           {
               cin>>s;
               sum+=value(c)*10+value(d);
               cout<<sum<<endl;
           }
       }
       else
       {
           cin>>s>>c;
           cin>>d;
           if(d[0]=='=')
            {
                sum=sum*10+value(b)+value(c);
                cout<<sum<<endl;
            }
           else
           {
               cin>>s;
               sum=sum*10+value(b)+value(c)*10+value(d);
               cout<<sum<<endl;
           }
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值