POJ2891 Strange Way to Express Integers(解多元线性同余方程)(中国剩余定理非互质版)(例题)

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input
2
8 7
11 9
Sample Output

31


题目大意:

选择a1,a2....ak,对于某个整数m分别对ai求余对应整数ri,现在已知a1,a2,....ak,以及整数对(ai,ri),求非负整数m的值,若有多个m,输出最小的一个。

解题思路:
容易列出方程 m % ai = ri,可以转化为同余方程 m ≡ ri (mod ai),接着套用求解多元线性同余方程的模版即可。

#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;
void ex_gcd(ll a,ll b,ll&d,ll&x,ll&y)
{
    if(!b)
    {
        x=1,y=0,d=a;
    }
    else
    {
        ex_gcd(b,a%b,d,y,x);
        y=y-(a/b)*x;
    }


}
int main()
{
    ll n,a1,a2,r1,r2;
    ll a,b,c,d,x0,y0;
    int flag;
    while(~scanf("%lld",&n))
    {
        flag=0;
        scanf("%lld%lld",&a1,&r1);
        for(int i=1;i<n;i++)
        {
            scanf("%lld%lld",&a2,&r2);
            a=a1,b=a2,c=r2-r1;
            ex_gcd(a,b,d,x0,y0);
            if(c%d!=0)
                flag=1;
            int t=b/d;
            x0=(x0*(c/d)%t+t)%t;
            r1=x0*a1+r1;
            a1=a1*(a2/d);
        }
        if(flag)
            printf("-1\n");
        else printf("%lld\n",r1);
    }
    return 0;
}

中国剩余定理非互质版

    中国剩余定理求解同余方程要求模数两两互质,在非互质的时候其实也可以计算,这里采用的是合并方程的思想。下面是详细推导。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值