A water problem

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 730    Accepted Submission(s): 377


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is  73  days in Xixi a year and  137  days in Haha a year. 

Now you know the days  N  after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 

Input
There are several test cases(about  5  huge test cases).

For each test, we have a line with an only integer  N(0N) , the length of  N  is up to  10000000 .
 

Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 

Sample Input
  
  
10001 0 333
 

Sample Output
  
  
Case #1: YES Case #2: YES Case #3: NO
 

Author
UESTC
 

Source
 

Recommend

大数除法取余,模拟除法过程


#include <stdio.h>
#include <string.h>
using namespace std;

int main()
{
    int i;
    char ch[10000005];
    int mod, cnt = 1;
    while ( ~scanf ( "%s", ch ) )
    {
        int len = strlen(ch);
        mod = 0;
        for ( i = 0; i < len; i++ )
        {
            mod = (mod*10+ch[i]-'0')%10001;
        }
        if ( mod )
        {
            printf ( "Case #%d: NO\n", cnt );
        }
        else
        {
            printf ( "Case #%d: YES\n", cnt );
        }
        cnt++;
    }
}


代码菜鸟,如有错误,请多包涵!!!

如果有帮助记得鼓励我一下,谢谢!!!


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值