Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.<br>
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).<br>
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.<br>
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
简单题意:
给出一个序列,求出这个序列的最大和。
解题思路形成过程:
第一次解决dp的问题,动态规划,也就是说,求出局部的最大和并保存起来。接下来就用本身和前面保存的最大和相比较,选出最大值,到最后就能得到结果。
感想:
动态规划的思路,百变不离其宗,掌握了例题,就能一步一步做出最终的代码。
AC代码:
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int i,ca=1,t,s,e,n,x,now,before,max;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&now);
if(i==1)
{
max=before=now;
x=s=e=1;
}
else {
if(now>now+before)
{
before=now;
x=i;
}
else before+=now;
}
if(before>max)
{max=before,s=x,e=i;}
}
printf("Case %d:\n%d %d %d\n",ca++,max,s,e);
if(t)printf("\n");
}
return 0;
}
#include <cstdio>
using namespace std;
int main()
{
int i,ca=1,t,s,e,n,x,now,before,max;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&now);
if(i==1)
{
max=before=now;
x=s=e=1;
}
else {
if(now>now+before)
{
before=now;
x=i;
}
else before+=now;
}
if(before>max)
{max=before,s=x,e=i;}
}
printf("Case %d:\n%d %d %d\n",ca++,max,s,e);
if(t)printf("\n");
}
return 0;
}