进制转换

Problem Description
输入一个十进制数N,将它转换成R进制数输出。
 

Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。
 

Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
 

Sample Input
  
  
7 2 23 12 -4 3
 

Sample Output
  
  
111 1B -11



#include<iostream>
#include<cstdio>
#include<string.h>
#include<math.h>
#include<string>
#include<map>
#include<set>
#include<vector>
#include<algorithm>
#include<queue>
using namespace std;

int main()
{
    int n,r;
    int num[1000];
    while( cin >> n >> r ){
        bool isne = 0;
        if(n<0){
            n = -n;
            isne = 1;
        }
        int i=0;
        if(isne) putchar('-');
        for(;n!=0;i++){                         //important
            num[i] = n%r;
            n /= r;
        }
        for(int j=i-1;j>=0;j--){
            if(num[j]>9){
                cout << (char)(num[j]+55);      //10 - 'A' ...important
            }
            else{
                cout << num[j];
            }
        }
        putchar('\n');
    }
    return 0;
}

/*二进制 位操作写法
int i=0;
while(n){
	ans[i++] = n&1;
	n >>= 1;
}
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值