UVA694 UVALive5466 The Collatz Sequence【模拟】

281 篇文章 4 订阅
96 篇文章 5 订阅

An algorithm given by Lothar Collatz produces sequences of integers, and is described as follows:

Step 1: Choose an arbitrary positive integer A as the first item in the sequence.

Step 2: If A = 1 then stop.

Step 3: If A is even, then replace A by A/2 and go to step 2.

Step 4: If A is odd, then replace A by 3 ∗ A + 1 and go to step 2.

  It has been shown that this algorithm will always stop (in step 2) for initial values of A as largeas 109, but some values of A encountered in the sequence may exceed the size of an integer on manycomputers. In this problem we want to determine the length of the sequence that includes all valuesproduced until either the algorithm stops (in step 2), or a value larger than some specified limit wouldbe produced (in step 4).

Input

The input for this problem consists of multiple test cases. For each case, the input contains a singleline with two positive integers, the first giving the initial value of A (for step 1) and the second givingL, the limiting value for terms in the sequence. Neither of these, A or L, is larger than 2,147,483,647(the largest value that can be stored in a 32-bit signed integer). The initial value of A is always lessthan L. A line that contains two negative integers follows the last case.

Output

For each input case display the case number (sequentially numbered starting with 1), a colon, the initialvalue for A, the limiting value L, and the number of terms computed.

Sample Input

3 100

34 100

75 250

27 2147483647

101 304

101 303

-1 -1

Sample Output

Case 1: A = 3, limit = 100, number of terms = 8

Case 2: A = 34, limit = 100, number of terms = 14

Case 3: A = 75, limit = 250, number of terms = 3

Case 4: A = 27, limit = 2147483647, number of terms = 112

Case 5: A = 101, limit = 304, number of terms = 26

Case 6: A = 101, limit = 303, number of terms = 1


Regionals 1998 >> North America - North Central NA


问题链接UVA694 UVALive5466 The Collatz Sequence

问题简述:(略)

问题分析

  按照题意,模拟序列的计算过程即可。

  需要注意的是开始的a和最后的1都算一项!这是一个坑啊!

程序说明(略)

题记:(略)

参考链接:(略)


AC的C语言程序如下:

/* UVA694 UVALive5466 The Collatz Sequence */

#include <stdio.h>

int main(void)
{
    long long a, l, t;
    int caseno = 0, cnt;

    while(~scanf("%lld%lld", &a, &l) && (a != -1 || l != -1)) {
        cnt = 0;
        t = a;
        while(t <=  l) {
            cnt++;
            if(t == 1)
                break;

            if(t % 2 == 0)
                t /= 2;
            else
                t = 3 * t + 1;
        }

        printf("Case %d: A = %lld, limit = %lld, number of terms = %d\n", ++caseno , a, l, cnt);
    }

    return 0;
}





  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值