UVA10014 Simple calculations【数列】

There is a sequence of n + 2 elements a0, a1, . . . , an+1 (n ≤ 3000; −1000 ≤ ai ≤ 1000). It is known that


for each i = 1, 2, . . . , n. You are given a0, an+1, c1, . . . , cn. Write a program which calculates a1.

Input

The first line is the number of test cases, followed by a blank line.

  For each test case, the first line of the input contains an integer n. The next two lines consist ofnumbers a0 and an+1 each having two digits after decimal point, and the next n lines contain numbersci (also with two digits after decimal point), one number per line.

  Each test case will be separated by a single line.

Output

For each test case, the output should contain a1 in the same format as a0 and an+1.

  Print a blank line between the outputs for two consecutive test cases.

Sample Input

1


1

50.50

25.50

10.15

Sample Output

27.85


问题链接UVA10014 Simple calculations

问题简述:(略)

问题分析

  数列计算问题。

  先进行数列通项公式的推导,然后再套公式计算,事情就简单了。


程序说明(略)

题记:数学问题通常是先进行数学推导,再按照数学公式做计算。

参考链接:(略)


AC的C语言程序如下:

/* UVA10014 Simple calculations */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int t;

    scanf("%d", &t);
    while (t--) {
        int n;
        double a, b, sum = 0;

        scanf("%d", &n);
        scanf("%lf%lf", &a, &b);
        for(int i=0; i<n; i++) {
            double x;
            scanf("%lf", &x);
            sum += (n - i) * x;
        }
        printf("%.2f\n", (n * a + b - 2 * sum) / (n + 1.0));

        if(t)
            putchar('\n');
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值