UVA10929 You can say 11【大数模除】

Your job is, given a positive number N, determine if it is a multiple of eleven.

Input

The input is a file such that each line contains a positive number. A line containing the number ‘0’ is the end of the input. The given numbers can contain up to 1000 digits.

Output

The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.

Sample Input

112233

30800

2937

323455693

5038297

112234

0

Sample Output

112233 is a multiple of 11.

30800 is a multiple of 11.

2937 is a multiple of 11.

323455693 is a multiple of 11.

5038297 is a multiple of 11.

112234 is not a multiple of 11.

 

 

题链接UVA10929 You can say 11

问题简述:(略)

问题分析

  输入的整数很长,可能达到1000位,问能否被11整除。

  这是一个大数模除求余数问题,可以一边将数字字符串转换为10进制数一边进行模除取余数。

程序说明:(略)

题记:(略)

参考链接:(略)

 

AC的C++语言程序如下:

/* UVA10929 You can say 11 */

#include <bits/stdc++.h>

using namespace std;

const int ELEVEN = 11;
const int N = 1000;
char s[N + 1];

int main()
{
    while(~scanf("%s", s) && (s[0] != '0' || s[1] != '\0')) {
        int sum = 0;
        for(int i = 0; s[i]; i++) {
            sum *= 10;
            sum += s[i] - '0';
            sum %= ELEVEN;
        }

        printf("%s is %sa multiple of 11.\n", s, sum == 0 ? "" : "not ");
    }

    return 0;
}

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值