POJ1007 UVA612 UVALive5414 ZOJ1188 HDU1379 Bailian4086 DNA Sorting【排序+逆序数】

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 110791 Accepted: 44366

Description

One measure of "unsortedness’’ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence "DAABEC’’, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence "AACEDGG’’ has only one inversion (E and D)—it is nearly sorted—while the sequence ``ZWQM’’ has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of "sortedness’’, from "most sorted’’ to ``least sorted’’. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from "most sorted’’ to ``least sorted’’. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

East Central North America 1998

Regionals 1998 >> North America - East Central NA

问题链接POJ1007 DNA Sorting
问题简述:(略)
问题分析
    这个一个排序问题,需要先算一下每个字符串的逆序数,根据逆序数进行排序。算逆序数采用暴力法进行计算。
    若干个相同的题目,输入和输出格式略有不同,代码都分别给出来了!
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序(POJ1007)如下:

/* POJ1007 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv < b.inv;
}

int main()
{
    int n, m, i, j, k;
    while(~scanf("%d%d", &n, &m)) {
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
    }

    return 0;
}

AC的C语言程序(UVA612 UVALive5414)如下:

/* UVA612 UVALive5414 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv, id;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv != b.inv ? a.inv < b.inv : a.id < b.id;
}

int main()
{
    int t, n, m, i, j, k;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &m);
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
            d[i].id = i;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
        if(t) printf("\n");
    }

    return 0;
}

AC的C语言程序(ZOJ1188)如下:

/* ZOJ1188 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv < b.inv;
}

int main()
{
    int t, n, m, i, j, k;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &m);
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
        if(t) printf("\n");
    }

    return 0;
}

AC的C语言程序(HDU1379 DNA Sorting)如下:

/* HDU1379 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv < b.inv;
}

int main()
{
    int t, n, m, i, j, k;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &m);
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
    }

    return 0;
}

AC的C语言程序(Bailian4086 DNA Sorting)如下:

/* Bailian4086 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv, id;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv != b.inv ? a.inv < b.inv : a.id < b.id;
}

int main()
{
    int n, m, i, j, k;
    while(~scanf("%d%d", &n, &m)) {
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
            d[i].id = i;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值