【PAT】1021. Deepest Root (25)【深度优先搜索】

题目描述

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

翻译:一个无环连通曲线图可以被表示为一棵树。树的深度取决于选择的根节点。现在你需要找出使树的深度最大的根节点。这样的根节点叫做最深根节点。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

翻译:每个输入文件包括一组测试数据。对于每组测试数据,第一行包括一个正整数N(<=10000) 代表节点的个数,因此节点被标记为从1-N。接下来的N行,每一行包括两个毗邻节点,即一条边。

OUTPUT FORMAT

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print “Error: K components” where K is the number of connected components in the graph.

翻译:对于每组测试数据,输出一行每个的最深节点。如果这样的节点不是唯一的,用升序输出他们的编号。如果给出的曲线图不是树,则输出”Error: K components”,K是图中的相连部分数。


Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5


Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components


解题思路

这道题判断是否有多棵树可以用并查集解决,而判断根节点的方法为先搜索一点,找到最远的节点集,再在最远的节点集中挑选一点搜索,并集即为答案。(参考晴神宝典《算法笔记》)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<set>
#include<vector>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,data[10010],root[10010];
set<int>st;
set<int>::iterator ite;;
vector<int>dot[10010];
int ans[10010],ccount=0;
void init(){
    for(int i=1;i<=N;i++){
        data[i]=i;
    }
} 
int find(int x){
    if(data[x]==x)return x;
    else return data[x]=find(data[x]);
}
void unite(int a,int b){
    a=find(a);
    b=find(b);
    if(a==b)return ;
    else{
        if(a<b)data[b]=a;
        else   data[a]=b;
    }
}
bool occur[10010];
int Maxheight=0;
void dfs(int a,int height){ 
    occur[a]=true;
    if(height>Maxheight){
        Maxheight=height;
        st.clear();
    }
    if(height==Maxheight)st.insert(a);
    for(int i=0;i<dot[a].size();i++){
        int temp=dot[a][i];
        if(occur[temp]==false){
            dfs(temp,height+1);
        }
    }
} 
int main(){
    scanf("%d",&N);
    int a,b;
    init();
    for(int i=0;i<N-1;i++){
        scanf("%d%d",&a,&b);
        dot[a].push_back(b);
        dot[b].push_back(a);
        unite(a,b);
    }
    int flag=1;
    root[1]=1;
    for(int i=1;i<=N;i++){
        int temp=find(data[i]);
        if(!root[temp])flag++,root[temp]=1; 
    }   
    if(flag>1)printf("Error: %d components\n",flag);
    else{
        memset(occur,0,sizeof(occur));
        dfs(1,1);
        Maxheight=0;
        for(ite=st.begin();ite!=st.end();ite++)
        ans[ccount++]=*ite;
        memset(occur,0,sizeof(occur));  
        dfs(*st.begin(),1);     
        for(int i=0;i<ccount;i++)
        st.insert(ans[i]);
        for(ite=st.begin();ite!=st.end();ite++)
        printf("%d\n",*ite);
    } 
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大学生就业服务平台管理系统按照操作主体分为管理员和用户。管理员的功能包括学生档案管理、字典管理、试卷管理、试卷选题管理、试题表管理、考试记录表管理、答题详情表管理、错题表管理、法律法规管理、法律法规收藏管理、法律法规留言管理、就业分析管理、论坛管理、企业管理、简历管理、老师管理、简历投递管理、新闻资讯管理、新闻资讯收藏管理、新闻资讯留言管理、学生信息管理、宣传管理、学生管理、职位招聘管理、职位收藏管理、招聘咨询管理、管理员管理。用户的功能等。该系统采用了Mysql数据库,Java语言,Spring Boot框架等技术进行编程实现。 大学生就业服务平台管理系统可以提高大学生就业服务平台信息管理问题的解决效率,优化大学生就业服务平台信息处理流程,保证大学生就业服务平台信息数据的安全,它是一个非常可靠,非常安全的应用程序。 管理员权限操作的功能包括管理新闻信息,管理大学生就业服务平台信息,包括考试管理,培训管理,投递管理,薪资管理等,可以管理新闻信息。 考试管理界面,管理员在考试管理界面中可以对界面中显示,可以对考试信息的考试状态进行查看,可以添加新的考试信息等。投递管理界面,管理员在投递管理界面中查看投递种类信息,投递描述信息,新增投递信息等。新闻信息管理界面,管理员在新闻信息管理界面中新增新闻信息,可以删除新闻信息。新闻信息类型管理界面,管理员在新闻信息类型管理界面查看新闻信息的工作状态,可以对新闻信息的数据进行导出,可以添加新新闻信息的信息,可以编辑新闻信息信息,删除新闻信息信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值