【PAT】1063. Set Similarity (25)【set容器的使用】

题目描述

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

翻译:给你两个整数集合,他们之间的相似度被定义为Nc/Nt*100%,NC是两个集合之间共有的特定数字,Nt为两个集合中不同数字的总数。你的任务是计算给定一对集合的相似度。

INPUT FORMAT

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括一个正整数N(<=50)代表总集合数。接着N行,每行给出一个集合,首先是M(<=10^4),接着是M个在{0-10^9}范围内的整数。在集合输入完毕后,是一个正整数K(<=2000),跟着K行查询。每个查询包含一对集合编号(集合被编号为1-N)。一行内所有数字之间用空格隔开。

OUTPUT FORMAT

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

翻译:对于每组查询,输出一行集合之间的相似度,用百分比表示并保留一位小数。


Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%


解题思路

题目都明确指出set了,那当然是使用set容器了。两个集合中交集的个数需要遍历一个集合,然后用count()函数判断是否在另一个集合中出现; 并集的个数为两个集合的size()之和减去交集数。输出时记得转换为百分比输出。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<set> 
#include<algorithm>
#define INF 99999999
using namespace std;
set<int> st[60];
set<int>::iterator it;
int N,K;
int main(){
    scanf("%d",&N);
    int M;
    for(int i=1;i<=N;i++){
        scanf("%d",&M);
        int a;
        for(int j=0;j<M;j++){
            scanf("%d",&a);
            st[i].insert(a);
        }
    }
    scanf("%d",&K);
    int p,q;
    for(int i=0;i<K;i++){
        int sum,common=0;
        scanf("%d%d",&p,&q);
        for(it=st[p].begin();it!=st[p].end();it++){
            if(st[q].count(*it))common++;
        }
        sum=st[p].size()+st[q].size()-common;
        double ans=common*1.0/sum;
        ans*=100;
        printf("%.1lf%%\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值