【PAT】1074. Reversing Linked List (25)【链表的使用】

题目描述

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

翻译:给一个常量K和一个单链表L,你需要将每K个L上的元素倒置。举个例子,如果给定的L为 1→2→3→4→5→6,如果K为3,则你必须输出 3→2→1→6→5→4; 如果K为4,则你必须输出4→3→2→1→5→6。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括头结点的地址,一个正整数N(<=10^5),代表总节点数,和一个正整数K(<=N),代表节点总数,和一个正整数K(<=N),代表需要转置的长度K。节点的地址为一个5位非负整数,-1代表NULL。

OUTPUT FORMAT

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

翻译:对于每组输入数据,输出按照要求执行后的链表。每个节点占一行,并且根据输入格式输出。


Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1


解题思路

先搜索一遍链表,将节点按照原链表顺序添加到vector中,再根据题目描述,如果vector长度大于等于K,则倒序将前K个压入结果vector中,并将前K个节点删除,小于K时就正序压入。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector> 
#include<algorithm>
#define INF 99999999
using namespace std;
struct node{
    int id,key;
    node(){}
    node(int ID,int k):id(ID),key(k){}
}d[100010];
vector<node> v;
vector<node> ans;
int S,N,K;
int main(){
    scanf("%d%d%d",&S,&N,&K);
    int id1,key,id2;
    for(int i=0;i<N;i++){
        scanf("%d%d%d",&id1,&key,&id2);
        d[id1].id=id2;
        d[id1].key=key; 
    }
    while(S!=-1){
        v.push_back(node(S,d[S].key));
        S=d[S].id;
    }
    while(v.size()>=K){
        for(int i=K-1;i>=0;i--){
            ans.push_back(v[i]);
        }
        v.erase(v.begin(),v.begin()+K);
    }
    for(int i=0;i<v.size();i++){
        ans.push_back(v[i]);
    } 
    for(int i=0;i<ans.size();i++){
        if(i==ans.size()-1)printf("%05d %d -1\n",ans[i].id,ans[i].key);
        else printf("%05d %d %05d\n",ans[i].id,ans[i].key,ans[i+1].id);

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值