【PAT】1104. Sum of Number Segments (20)【数学公式】

解题思路

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

翻译:给定一个正整数数列,一个段被定义为一个连续的子序列。例如,给定数列 { 0.1, 0.2, 0.3, 0.4 }, 我们有10个段:(0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) 和(0.4)。
现在给定一个数列,你需要找到所有段的所有数字的和。对于之前的例子,所有十个段之和为0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10​5​​ . The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括一个正整数N,代表数列的长度,不超过105。接下来一行为包含N个正数的数列,每个数字都不超过1.0,用空格隔开。

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

翻译:对于每组测试数据,输出一行所有段的数字之和,结果保留两位小数。


Sample Input:

4
0.1 0.2 0.3 0.4


Sample Output:

5.00


解题思路

这道题主要是找规律,发现每个数列中的数字需要被乘(n-i)*(i+1)次后就可以轻松写出了。注意(n-i)*(i+1)可能会超出整数范围,要用long long int 或 double 类型保存。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
#define bug puts("Hello\n")
using namespace std;
int N;
double v[100010];
double sum=0.0;
int main(){
	scanf("%d",&N);
	for(int i=0;i<N;i++){
		scanf("%lf",&v[i]);
		long long int tmp=0;//防止整型溢出 
		tmp=N-i;
		tmp*=(i+1);
		sum=sum+tmp*v[i];
	}
	printf("%.2lf\n",sum);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值