【PAT】1132.Cut Integer (20)【模拟】

题目描述

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

翻译:将一个整数截断意味着将一个K个数位的长整数Z截成两段长为(K/2)个数位的长整数A和B。例如,在对Z=167334进行截断后,我们得到了A=167和B=334。有趣的是Z可以被A和B整除,167334 / (167 × 334) = 3。给定一个正整数Z,你需要测试它是否是一个整数。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31). It is guaranteed that the number of digits of Z is an even number.

翻译:每个输入文件包含一组测试数据。对于每组测试数据,第一行给定一个正整数N (≤ 20)。接下来N行,每行给定一个正整数Z (10 ≤ Z <2​31)。数据保证Z的数位为一个偶数。

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

翻译:对于每组测试数据,如果是这样的数输出一行Yes,否则输出No。


Sample Input:

3
167334
2333
12345678


Sample Output:

Yes
No
No


解题思路

模拟题目要求即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
#define bug puts("Hello\n")
using namespace std;
int N;
int CountSize(int a){
	int ccount=0;
	while(a){
		a/=10;
		ccount++;
	}
	return ccount;
}
int main(){
	scanf("%d",&N);
	int a;
	for(int i=0;i<N;i++){
		scanf("%d",&a);	
		int wei=CountSize(a);
		int tmp=pow(10,wei/2);
		int num1=a/tmp,num2=a%tmp;
		int tmpnum=num1*num2;
		if(tmpnum!=0&&(a/tmpnum*tmpnum==a)){
			printf("Yes\n");
		}
		else printf("No\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值