1039

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11083    Accepted Submission(s): 5356


Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
 

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
 

Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.
 

Sample Input
  
  
a tv ptoui bontres zoggax wiinq eep houctuh end
 

Sample Output
  
  
<a> is acceptable. <tv> is not acceptable. <ptoui> is not acceptable. <bontres> is not acceptable. <zoggax> is not acceptable. <wiinq> is not acceptable. <eep> is acceptable. <houctuh> is acceptable.





    要认真读题啊

    1.至少要有一个元音;

    2.不能出现3个连续辅音或3个连续元音;

    3.不能有两个连续相同的字母(除了'e'和'o')//最开始就错在这,可以出现'ee'和'oo',但不用去判断三个'e'的情况,因为这已经被条件2给否定了。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

#define MAXN 6666666

using namespace std;

char kkke[MAXN];

inline bool is_vowel(char c)
{
	switch(c)
	{
		case 'a':
		case 'e':
		case 'i':
		case 'o':
		case 'u':
			return true;
		default:
			return false;
	}
}
int main()
{
	freopen("input.txt","r",stdin);
	freopen("output.txt","w",stdout);
	while(scanf("%s",kkke),strcmp(kkke,"end"))
	{
		bool ans=is_vowel(kkke[0]);
		int cnt=1;
	    for(int i=1;kkke[i]!='\0';i++)
	    {
	    	if(!ans&&is_vowel(kkke[i]))ans=true;
	    	//if(kkke[i]==kkke[i-1])
	    	if(kkke[i]!='e'&&kkke[i]!='o'&&kkke[i]==kkke[i-1])
	    	{
	    		ans=false;
	    		break;
	    	}
	    	
	    	if(is_vowel(kkke[i])==is_vowel(kkke[i-1]))cnt++;
	    	else cnt=1;
	    	if(cnt>=3)
	    	{
	    		ans=false;
	    		break;
	    	}
	    }
		if(ans)printf("<%s> is acceptable.\n",kkke);
		else printf("<%s> is not acceptable.\n",kkke);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值