1015 of dop

Problem O

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 77   Accepted Submission(s) : 58
Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

Input
For each case there is a postive number n on base ten, end of file.
 

Output
For each case output a number on base two.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 10 11
   简单的二进制转换。通过循环除以2取余数得到一个数组,反向输出即可。
   解题代码:
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
   long long int flag,t,i;
   int a[1000];
   while(cin>>i)
   {
       flag=0;
       while(i!=0)
       {
           a[flag]=i%2;
           i/=2;
           flag++;
       }
       for(i=flag-1;i>=0;i--)
        cout<<a[i];cout<<endl;
   }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值