HDU 4282 A very hard mathematic problem

A very hard mathematic problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5818    Accepted Submission(s): 1644


Problem Description
  Haoren is very good at solving mathematic problems. Today he is working a problem like this: 
  Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
   X^Z + Y^Z + XYZ = K
  where K is another given integer.
  Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
  Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
  Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
  Now, it’s your turn.
 

Input
  There are multiple test cases. 
  For each case, there is only one integer K (0 < K < 2^31) in a line.
  K = 0 implies the end of input.
  
 

Output
  Output the total number of solutions in a line for each test case.
 

Sample Input
  
  
9 53 6 0
 

Sample Output
  
  
1 1 0   
Hint
9 = 1^2 + 2^2 + 1 * 2 * 2 53 = 2^3 + 3^3 + 2 * 3 * 3
 

Source
 

Recommend
liuyiding
 
题意:在x、y、z都为正整数,x<y且z>1的条件下,存在多少个x、y、z,使得x^z + y^z + xyz = k,0<k<2^31;
思路:根据题意大概可以知道,y最小取2,即可得z<31,而x、y最大只能为pow((2^31),1/z),然后就可以枚举z和x,  二分查找y,减少时间的复杂度;
代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <set>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
typedef long long LL;
LL fast_pow(LL a,LL b)//快速幂
{
	LL ans = 1;
	while(b)
	{
		if(b&1)
		{
			ans *= a;
		}
		a *= a;
		b >>= 1;
	}
	return ans;
}
int main()
{
#ifdef OFFLINE
	freopen("t.txt","r",stdin);
#endif
	LL k,num;
	while(scanf("%lld",&k) && k)
	{
		num = 0;
		for(LL z = 2; z< 32; z++)
		{
			LL p = pow(double(fast_pow(2,31)),1.0/z);//求出x和y枚举的上限,不这样会爆LL的
			for(LL x = 1; x<= p;x++)
			{
				LL a = fast_pow(x,z);
				if(a >= k)break;//如果a(即x^z)都大于k,直接跳出
				LL left = x+1,right = p,mid;//使得y>x
				while(left <= right)//二分查找y
				{
					mid = (left + right)>>1;
					LL b = fast_pow(mid,z);
					LL p = a + b + x*mid*z;
					if(p == k)
					{
						num++;
						break;
					}
					else if(p > k)
					{
						right = mid - 1;
					}
					else
					{
						left = mid + 1;
					}
				}
			}
		}
		printf("%lld\n",num);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值