PAT (Advanced Level) 1015. Reversible Primes (20) 翻转质数

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
质数按给定进制逆序后,再转为十进制,仍为质数。使用一个数组作辅助,简单题。
/*2015.7.20cyq*/
#include <iostream>
#include <vector>
using namespace std;

bool prime(int n){
	if(n<=1)
		return false;
	if(n==2||n==3)
		return true;
	for(int i=2;i*i<=n;i++){
		if(n%i==0)
			return false;
	}
	return true;
}

int reverse(int n,int radix){
	vector<int> tmp;
	while(n){//低位在前,逆序压入
		tmp.push_back(n%radix);
		n=n/radix;
	}
	int sum=0;
	for(auto it=tmp.begin();it!=tmp.end();++it){
		sum=sum*radix+*it;
	}
	return sum;
}

int main(){
	int a,r;
	cin>>a;
	while(a>0){
		cin>>r;
		if(prime(a)&&prime(reverse(a,r)))
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;
		cin>>a;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值