DFS_ZOJ1002

该问题涉及在一个有墙壁的正方形城市地图上放置尽可能多的四面射击的堡垒,条件是堡垒之间不能直接相互摧毁。合法的堡垒配置要求同一行或同一列的堡垒之间至少有一堵墙隔开。任务是为给定的地图计算最大数量的合法堡垒布置。输入包含多个地图描述,以0结束,每个描述包括地图大小和由'.'和'X'表示的空地和墙壁的排列。输出应为每个测试案例的最多可放置堡垒数。
摘要由CSDN通过智能技术生成
Fire Net

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Suppose that we have a square city with straight streets. A map of a city is a squareboard with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand,a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city aspossible so that no two can destroy each other. A configuration ofblockhouses is legal provided that no two blockhouses are on the samehorizontal row or vertical column in a map unless there is at least one wallseparating them. In this problem we will consider small square cities (at most 4x4) that contain walls through whichbullets cannot run through.

The following image shows five pictures of the same board. Thefirst picture is the empty board, the second and third pictures show legalconfigurations, and the fourth and fifth pictures show illegal configurations.For this board, the maximum number of blockhouses in a legal configurationis 5; the second picture shows one way to do it, but there are severalother ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in thecity in a legal configuration.

The input file contains one or more map descriptions, followed bya line containing the number 0 that signals the end of the file. Eachmap description begins with a line containing a positive integer nthat is the size of the city; n will be at most 4. The next nlines each describe one row of the map, with a '.' indicating anopen space and an uppercase 'X' indicating a wall. There are nospaces in the input file.

For each test case, output one line containing themaximum number of blockhouses that can be placed in the cityin a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4
/**
**author :Stephen Liu **
**    **
**--**
**2013--  --  **
**/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <queue>
#include <stack>
#include <vector>
using namespace std;
char cMap[10][10];
int n,iBest;
bool Canput(int row,int col)
{
    for(int i=row;i>=0;i--)
    {
        if(cMap[i][col]=='o')   return false; //行中如果存在碉堡就不能添加
        if(cMap[i][col]=='X')   break;       //存在'X'
    }
    for(int i=col;i>=0;i--)
    {
        if(cMap[row][i]=='o')   return false;  //行中如果存在碉堡就不能添加
        if(cMap[row][i]=='X')   break;  //存在‘X’
    }
    return true;
}
void Solve(int k,int current)   //递归构造最大解
{
    int x,y;
    if(k==n*n)
    {
        if(iBest<current)
            iBest=current;
        return;
    }
    else
    {
       x=k/n;
       y=k%n;
       if(cMap[x][y]=='.'&&Canput(x,y))
       {
           cMap[x][y]='o';
           Solve(k+1,current+1);
           cMap[x][y]='.';
       }
    }
    Solve(k+1,current);
}
int main()
{
	//freopen("in.txt","r",stdin);
	while(scanf("%d",&n)!=EOF&&n!=0)
	{
	    memset(cMap,0,sizeof(cMap));
	    for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                cin>>cMap[i][j];
        iBest=-1000;
        Solve(0,0);
        printf("%d\n",iBest);
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值